Linux installation - how about a proper .deb or even better, .appimage?

Hi Guys,

I’ve just spent half of the morning battling with the terminal, trying to get Brave installed on Linux Mint 19.1…

The installation instructions on the website didn’t work. I had to dig around the various forums to find an answer. Even so, it’s like jumping through flaming-hoops to get it up and running. Christ, even Chromium was easier to install…

Don’t mean to sound too crytical, but we live in the 21st century; Is it really that difficult to provide a simple and secure installer for Linux (.deb or .appimage)?

Cheers,

Mike.

@mingle I’m not familiar with Linux. Did steps mentioned here not working for you?

https://brave-browser.readthedocs.io/en/latest/installing-brave.html#linux

I see there’s Mint 18+ listed there.

Also, here, there’s .deb listed https://github.com/brave/brave-browser/releases/tag/v0.66.99 (*)

(*) It’s for the latest stable release

Hi,

I’ve tried the .deb file you mentioned, but it says I need the brave keyring package as a prerequisite.

I never need, or use ANY keyring functions in Linux, so is there any way of using brave without the keyring.

Cheers,

Mike.

cc @Mattches @sriram for additional assistance here.

@mingle I am able to install using the instructions that is provided under Mint 18+


image

This is on a clean VM so everything is clean. It could be possible that you tried installing the older Mint commands which is right below one other.

curl -s https://brave-browser-apt-release.s3.brave.com/brave-core.asc | sudo apt-key --keyring /etc/apt/trusted.gpg.d/brave-browser-release.gpg add -

The above command should add the keyring automatically and shouldn’t complain if that worked correctly. Do you mind taking screenshot of your terminal when you run the commands from here

Hi Sriram,

Thanks for the reply…

The issues I have is that I do not want or need the Brave Keyring package - just the Brave browser, but the .DEB requires the keyring package as a pre-requisite.

Is it possible to remove the keyring package after the browser is installed, or will that break things?

It seems strange that it’s a prerequisite and not an option.

Cheers,

Mike.

On the use of Terminal to install, there’s the option of using Synaptic Package Manager, adding the Brave repositories, then updating, then searching for Brave and installing. If you want some help doing that, the previous responders or I can provide that.

However, that will still result in installing the Brave keyring, which I believe is used to ensure authenticity of Brave and… Hm. @sriram and @Mattches, what does the keyring do? I’ve never seen anyone complain about it’s presence and assumed it was a component needed for security.

@mingle,
When you run the command:

curl -s https://brave-browser-apt-release.s3.brave.com/brave-core.asc | sudo apt-key --keyring /etc/apt/trusted.gpg.d/brave-browser-release.gpg add -
  1. It downloads a copy of the Brave public key – this is used to sign the packages we distribute.
  2. It then adds this signing key to a new keyring that the OS package manager can use to ensure that the downloaded brave-browser packages did in fact come from Brave Software.

The keyring is there to ensure data integrity and keep users safe from bad actors and fake sites. Is there a particular reason you are trying to avoid the keyring?

2 Likes

Basically what @Mattches said about keyring. Also Keyring basically has the validation certificates so that it checks integrity of the download. If anyone tries to change the package then keyring would basically fail the integrity check and you would see an error when do sudo apt update . If you just want to download the .deb file you can always use our github repo to download the latest release of stable/beta/dev/nightly channels.

1 Like

I’m using older hardware, so I’m using Mint 17+ I have tried Synaptic, (NO Brave repos are any good), as well as in terminal, (NO repos are any good), in release, beta, dev or nightly. As a matter of fact, just an ordinary system update gets stalled, (or, GOT stalled because I took out the Brave repos)…“Keyring” is a fault and so is “malformed line”.

Screenshot%20from%202019-07-26%2014%3A41%3A45

Little help?

Hi, @RevLouM. It looks like you used the steps from the Linux page that are meant for Linux Mint 18+ since they have the variable @UBUNTU_CODENAME instead of the actual codename (trusty). That’s almost certainly the problem. Note that in your echo of the added repository, there is no codename included - it has the URL ‘…com/ main’ instead of ‘…com trusty main’ and I’m guessing that’s the problem resulting in the malformed line error and the inability of the OS to find the update packages.

On the Linux install page linked above, if you scroll down a bit you’ll find a different set for Mint 17 that use the codename trusty instead of the variable for the repository. Try doing the echo step on again with trusty instead of the variable and see if that works. In other words, try:
echo "deb [arch=amd64] https://brave-browser-apt-release.s3.brave.com/ trusty main" | sudo tee /etc/apt/sources.list.d/brave-browser-release-trusty.list

sudo apt update

sudo apt install brave-browser

For good measure, here are the Mint 17 steps quoted from the install page:

Debian 9, Ubuntu 14.04 and Mint 17

sudo apt install apt-transport-https

curl -s https://brave-browser-apt-release.s3.brave.com/brave-core.asc | sudo apt-key --keyring /etc/apt/trusted.gpg.d/brave-browser-release.gpg add -

echo "deb [arch=amd64] https://brave-browser-apt-release.s3.brave.com/ trusty main" | sudo tee /etc/apt/sources.list.d/brave-browser-release-trusty.list

sudo apt update

sudo apt install brave-browser

HI Guys,

I guess I have to live with the keyring.

The other issue I have is that the Linux install instructions are not clear about how to configure the terminal commands for specific versions of Ubuntu/Mint.

In fact I only figured it out myself when I saw one of your previous replies, showing the correct commands for the Ubuntu “trusty”.

I was trying upper-case, capilatilsed first letter, leaving the “{ }” around the commands… It’s really very unclear, with no clear example.

Anyway, I think you should make an effort to get it properly set up on the Linux Mint repositories, as an average user (I conisder myself to be reasonably competant) would have no chance of getting it installed without similar dramas.

Cheers,

Mike.

… or at least fix the .DEB package, so it also installs the brave keyring…

… or BETTER STILL - an Appimage!

Chers,

Mike.

Thank you much. I shall try that in the morning! Cheers.

Thanks. IDK what, exactly, I’m doing wrong. I Tried, CLi, typing it all in and then I tried copy & paste and I tried to at the very least get the Synaptic to recognize the repo. Nothing. I’m trying to figure out if I can, in fact, move to Mint 18 but haven’t found an answer to that yet…If I can move it, I gather the problem will be self sorting?

Thanks again!

S/S of the message I get when I open Synaptic:

You added the trusty repository fine. What it did was add a file in /etc/apt/source.list.d named brave-browser-release-trusty.list, and that file contains the repository from the echo statement. You can check in Terminal by typing less /etc/apt/sources.list.d/braver-browser-release-trusty.list and hitting return (type q if it displays file contents).

I think the problem from your sudo apt update on is that the bad entry file from before is still in the repository list directory and needs to be removed. There are a few ways to do this. Synaptic Package Manager may be the “best,” but I think all you really have to do is delete the file /etc/apt/sources.list.d/braver-browser-release-.list (sudo rm /etc/apt/sources.list.d/braver-browser-release-.list), then try sudo apt update again since the -trust.list file should still be there.

Upgrading the OS won’t fix the repository list issue unless it’s a clean install that wipes the /etc/apt/sources.list.d, I believe, so you still need to be sure the bad file is deleted.

That said, the move to Mint 18 can work. What I did when I jumped from 17 to 19 was move my home directory to another partition/drive to separate operations on the OS from operations on my stuff. It seemed to work. You can then do a clean install of the OS and tweak it to use the “external” home directory. I did it, but I used a guide. Here are a couple to take a look at:
https://community.linuxmint.com/tutorial/view/1609
https://help.ubuntu.com/community/Partitioning/Home/Moving

The first one is Mint-specific. The second one is for Ubuntu, but Mint is based on Ubuntu, so it should still be okay. I think I used the Mint-specific one, but it was a year or two ago, so I’m not sure.

SOLVED. (ish) I should have paid slightly more attention to some of the other issues! What I FOUND was KEYRING. I went to Software Sources and deleted the repos for Brave. All of 'em. But, then Brave, of course, disappeared. So I searched. Found Keyring. Marked for complete removal. All other repos loaded with no errata and Synaptic didn’t abend. Went to Brave site and loaded up. Here I am. Thanks for the help!

1 Like

Excellent! Congrats on debugging your system!

@mingle, did you get your Brave up and running?