Leo won't respond

Hey there!

I am running the latest version of Brave, and Leo won’t respond to me. I’ve tried both with and without context, I’ve opted in, and I’ve checked my settings. I’ve also tried restarting my browser and computer multiple times.

Here’s what Brave says about my current version:

Brave is up to date


Version 1.60.125 Chromium: 119.0.6045.199 (Official Build) (64-bit)

Here’s a screenshot of me trying to chat with Leo and waiting a long time for responses with nothing back:

I’ve tried from the address bar, from the sidebar, with and without context, on a new tab, etc. Leo just won’t respond to me.

1 Like

Thank you for reaching out to us. We did just fix an issue that resolves a similar issue.

Can you tell me if changing the model (Settings —> Leo) makes any difference?

@Mattches I am not on Premium, so I can’t technically use any of the other models. Settings did allow me to select one of the Premium models as the default for new chats, but new chats still open the non-Premium 13b model as expected. I am still experiencing the same issue where I get no response from Leo and have tested again with and without context, in new tabs, on pages, via she search bar, etc.

@blindy,
Apologies — shouldn’t have assumed you were on Premium. I’ve pinged our devs and should have more information for you soon.

@blindy,
Are you seeing this behavior on your home PC or or are you on a work machine/network? If so there’s a chance that there is a corporate firewall blocking the response.

@Mattches I am experiencing this behavior on a work computer. Leo doesn’t work even if I’m not signed into the VPN. I checked, and Leo is working on my personal computer, so that’s likely it.

Do you know how I could either get Leo working myself, or is there more information I can share with my company’s IT if they’re willing to enable it?

1 Like

At least we found out the cause for the initial issue.

I do not know how you can get Leo working at your workspace, unfortunately. Since you have to connect through their network it’s unlikely that there is any bypass. I would recommend just asking them about it — feel free to share any of our resources (note the footnotes as well):

Okay, thanks for your support!

1 Like

@Mattches I wonder if you have considered having an option to proxy through Tor a lot or all of the communications from brave browser to Brave’s servers, including Leo calls in this case. I was going through the documents where Brave has described the threat model for various of it’s anonymity preserving systems, like the auto-contribute system for BAT and there’s always the assumption that the CDN will not collude with Brave Inc. and that it will actually always discard the IP addresses. It sounds like a easy fix to try and route them through Tor. If bridges were used it could also be a fix for @blindy’s problem too.

1 Like

Leo is not working on my Windows 11 laptop. I type a prompt and he doesn’t respond to anything.