Ios AutoFill Brave Passwords from Brave ios Browser

Description of the issue:
Brave does not autofill passwords on websites.

How can this issue be reproduced?

  1. Go to any website where there is a saved password in Brave
  2. Type username

Expected result:
Option to select a username or autofill a password

Brave Version( check About Brave):
1.43 (
I had the same problem on older versions as well.

Mobile Device details
iPhone 12 Pro
iOS 16.0.2

Additional Information:
I have all passwords within Brave, Synced which are accessible from settings.
They don’t auto-fill.



Hello there @johnsweeney85 please accept my apologies for this inconvenience. Please do the following to manage your saved information:

  1. Launch Brave
  2. Open the Menu in the top right.
  3. Go to Settings --> Additional Settings --> Autofill or brave://settings/autofill
  4. At the top, select which form type you’d like to manage
  5. Toggle on the autofill option you would like to set and make sure your information is correct.

Let me know if that works.

Under settings I have no additional settings. In addition saved passwords are not auto filling. This seems to be when the browser is set to private mode with no history.

1 Like

this is not for the iOS version (or Android version)

the Brave passwords will not autofill like the built-in apple keychain or third-party apps, if your they do not show up in the proper text fields you’ll have to copy & paste from the passwords section on the browser, i sometimes get this problem with any iOS browser i’m using. its a bit of a pain i know, but i’m not sure any third party browser has really got it totally sorted yet

Strange I was thrown by the words at the top of page!

1 Like

Hello again could you please try deleting your cookies from the app to see if the issue is solved?

  1. In Brave, open the main menu, then Settings --> Privacy. Note: You can also select Menu --> History --> Clear browsing data
  2. Select Clear browsing data

Let me know if that works.

Hi Kevin, thanks for writing to me. I hope you can read this the colour is very strange!
I have tried your suggestions with no luck. I have such things turned on anyway.
If I turn off all the privacy features it’s works, but I do like my privacy!
Thanks you for contacting me.

1 Like

Hi again @Sledman could you please double check that you have the latest Brave version installed? As the password manager should be able to work with Shields on.

Be waiting for your response.

Hi @Kevin_cc, @johnsweeney85 and Sledman appear to have dropped off. I’d be happy to continue troubleshooting this with you as I am having the same issue. I cannot use Brave browser on iOS because none of my saved usernames/passwords work. I have cleared my cookies and I am using version 1.45.2 ( It doesn’t say whether this is the newest version or whether there is an update available. My usernames/passwords still aren’t working.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.