Installing Brave Inside Crostini


Description of the issue: Installing Brave inside the Chrome OS Crostini container.
I was primarily interested in using Jupyter Lab from inside the Crostini container so that it would start directly into Brave. (Trying for a small, fast browser since a Chromebox tends to be fairly small.) This is the solution, but I thought others might want the information.

Steps to Reproduce (add as many as necessary): 1. 2. 3.
There are three primary issues:

(1) the file /etc/os-release doesn’t contain the value UBUNTU_CODENAME, so

(a) the file /etc/apt/sources.list.d/brave-browser-beta-${UBUNTU_CODENAME}.list is misnamed since UBUNTU_CODENAME is not defined by “source /etc/os-release”
(b) inside the above file, the format is wrong since UBUNTU_CODENAME is not defined

(2) the BROWSER is defined as “BROWSER=/usr/bin/garcon-url-handler” since the Crostini container wants to ship handling to the Chrome browser running under the Chrome OS.

(3) The directory

As a rule, you probably don’t want to change BROWSER permanently since you probably want the integration between the Chrome OS and the container, but I just want to have a nice Jupyter Lab environment.

Actual Result (gifs and screenshots are welcome!):

I changed the standard commands to the following:

curl -s | sudo apt-key --keyring /etc/apt/trusted.gpg.d/brave-browser-beta.gpg add -

export UBUNTU_CODENAME=xenial

echo "deb [arch=amd64] UBUNTU_CODENAME main" | sudo tee /etc/apt/sources.list.d/brave-browser-beta-{UBUNTU_CODENAME}.list

sudo apt update

sudo apt install brave-browser-beta

NOTE: You can edit the file /etc/apt/sources.list.d/brave-browser-beta-xenial.list manually to achieve the same effect, but this works fairly easily.

In my .bashrc file I added an alias

alias activatePython=“conda activate PythonStandard;export BROWSER=brave-browser-beta;cd ${HOME}/PythonStandard”

This activates my python environment, sets the BROWSER as Brave (but only for that temina) and changes to the correct directory. I then execute “jupyter lab” to start the JupyterLab environment.

Expected result:
In addition to setting this up for the use with the Jupyter Lab environment, this also puts the Brave badge down on the shelf when it is opened.

Reproduces how often:
The fix seems to work well, but you need to find the right code base to use. I tried trusty and xenial and they both seem to work.

Brave Version(See the About Brave page in the main menu):
I used the beta channel.

Reproducible on current live release (yes/no):
This is just a minor update to installation instructions, but probably.

Additional Information:
This isn’t a bug so much as a way to fix a problem with the latest Crostini implementation in a Chromebox or Chromebook. I couldn’t find this so I submitted it this way.


closed #2

This topic was automatically closed after 30 days. New replies are no longer allowed.