Problem installing via Linux in Chromebook

I have tried to install on my Chromebook via Linux, using the instructions here:

Everything goes well until the end, when it says: “E: Unable to locate package brave-browser-beta”. I try over and over with no luck. Really want to install Brave. Please help.

Description of the issue:
How can this issue be reproduced?

Expected result:

Brave Version( check About Brave):

Additional Information:

Do you have playstore available on your Chromebook? You should be able to install it via PlayStore if available.

Alternately please follow the steps from here https://www.linuxmadesimple.info/2020/03/how-to-install-brave-browser-on.html (video at the bottom of the article). Its not official documentation but just a helpful guide

Thanks sriram. I do have Playstore on my Chromebook, but the app version is not the same full desktop version. [like on my S20, Tab A, Windows PC] I’ll already tried the instructions on that link and it gave the same error.

Any other suggestions???
Thanks

While we don’t officially support that configuration, we’ve had reports of this working with the Debian installation instructions. Have you tried the stable channel or just beta?

If you can copy logs of the output, it might be helpful in trying to help you figure out the point at which it’s failing.