Im unable to complete brave rewards captcha

Description of the issue:
as seen in this video: I am unable to complete the captcha necessary to redeem my brave rewards. I believe that the browser may be attempting to drag the image normally instead of any custom drag behavior that the captcha might use.

Steps to Reproduce (add as many as necessary):

  1. Click the redeem rewards option (maybe you must have an unverified wallet like me and/or be on the beta while using KDE Linux)
  2. Attempt the Captcha but nothing happens(When I try to drag the image it seems to move but in a semitransparent way when you normally drag images(like into a new tab to see the image on its own.) )

Expected Result:
To be able to complete the Captcha and redeem my rewards.

Reproduces how often:

Brave Version(See the About Brave page in the main menu):
Version 1.35.75 Chromium: 97.0.4692.71 (Official Build) beta (64-bit)

latest beta at the time of posting: V 1.35.75

Reproducible on current live release (yes/no):

Additional information:
Im using kubuntu 20.10


I’m having the same problem, also using Linux (Manjaro).

I am using version V1.34.80 (Jan 6, 2022) on ubuntu lts 20.04 and I have the same problem. I cannot claim the reward because the captcha fails to work correctly. If this cannot be corrected to work reliably this should be removed. You guys had trouble with this since October, it is time to correct it. I suspect the Captcha is not need. and is just an annoyance.

thank you,

1 Like

I don’t really see the point in requiring a captcha for redeeming your rewards, if a bot is getting BAT automatically then a human would easily be able to redeem it manually at the end of the month. I would think that redeeming the rewards is the time which it is the least important to check for bots. If I were developing brave, I would have it automatically transfer at the end of the month or better yet, give you the BAT as soon as you see the AD.

Also having the same problem on beta build on opensuse

Same problem. Hopefully there’s a patch soon.

Just to let others know, I managed to get around this issue by logging into a GNOME session, so the problem obviously lies with Plasma somewhere.

1 Like

Similar problem here. I can drag the BAT icon to the target but nothing happens except that BAT icon appears on my desktop :grin: (Linux Mint 19.1 Tessa)

HI @lpn, is this still an issue for you? Is your DPI set to 100%? Have you been able to successfully claim in past payouts?

Thanks for the info!

having same issue. after dragging the icon nothing happens. I’m using plasma.

how did you change your dpi setting to 100? I tried the dfconf tool without success. If I crack it I will say how I did it.

For me when I drag the image into place and release the mouse the image ends up on the desktop.

1 Like

Perhaps brave does not want to resolve this issue. If people cant figure it out they don’t get their earnings and brave keeps them. I was reviewing previous posts, these issue have persisted for 3 years. The truth is that brave could end the issues immediately by removing the captcha but they do not do it. If people become angry they will ditch the brave browser and look elsewhere. My expectation is that there is a resolve for this issue. I am using ubuntu 20.04 lts. Is there an easy resolve or not? As you can see I am losing my patience.

thank you,

wizardman (aka John)

Update: Once I switched to XFCE Desktop environment I could complete the Captcha. So it is only a problem on KDE plasma

It’s not just KDE. Mate is having the same issue. I think there will be a lot more complaints across desktops as more people try to claim.

I am also affected by this issue. I can drag the BAT icon, but nothing happens when I drop it. I am using the snap version 1.34.80 on KDE Neon.

The xfce desktop did it for me! With Ubuntu I was able to select my desktop environment before logging in in the notification bar at the top right. Once you are logged in with the xfce the captcha will work. After you finish with the captcha you can use any desktop environment you like.

If you don’t have the xfce desktop environment you can look up how to install it with your particular version of Ubuntu. All it takes to install it are a couple of commands and a reboot. Claim your reward!

thanks! that worked for me

switching to GNOME to claim my rewards worked for me