How to reverse Microsoft-Edge Protocol Handler?

Brave started freezing constantly after I make it default.

However there is no option to reverse it.

Does anyone know how to do it?
Thank you.

I am an English speaker only, so I can’t read the text on your image. So, if what I post doesn’t really address your issue, ignore! :smiley:

If I select Brave as my default Browser, I too don’t have the option to reverse that action in brave://settings. When I select the option, it also changes the default browser setting in my OS. I am using Win10.

To change it to another browser, I have to close Brave Browser. Go to windows default browser settings, and change the default browser there. When I open Brave again, the option to make Brave my default browser is back (disabled).

I’m going to test just to make sure the above still works the same way in the recent version update. I will let you know if it doesn’t.

1 Like

Thank you for your answer but I want to come back to the original setting, before make it default.


Do you know how to come to this option?
Do I have to unistall Brave and clean the key registers?

You shouldn’t need to use that option — simply open the Windows Default applications screen and select Brave as the default browser there.

I understand but I want to reverse this setting.
I made it default but I can’t reverse the process.

Just posting images (with questions lol) to see if I can help out.

This is where you make Brave the default browser.

This is the image you posted and the option you have outlined is not enabled. According to the snapshot, you did not make that option a default so there is nothing to reverse.

Can you please clarify.

P.S. What OS are you using?

Yeah I’m not clear on what the issue is exactly. If Brave is the default, then set the default to Edge (or some other browser) in the Default applications window to change the default browser from Brave to [Edge].

Here is the correct sequence:


As you can see I enabled this option and now I can’t reverse it.
I already unistalled Brave and even delete some key registers, but every time I reinstall Brave the Microsoft-Edge Protocol Handler is already enabled.

You can change your protocol handlers in Windows settings. Have you checked and tried to change there?

Is this what you are looking for?


@Chocoholic I think you are getting warmer. I have the same question. I don’t even know what the Default microsoft-edge protocol handler does but I could not find the "Choose file types and Protocols opened by each app in Windows 11. The closest I could find was choose defaults by link type but there was a lot of options in there.

@mike103 Ack, I know nothing about win11. My system is so old I don’t meet the specs to install! lol

I’ll help and do an internet search and see if I can find anything. I’ll post it here if I do. Sorry I can’t be of more help.

@mike103 Found these. They were published end of year last year but probably are still valid. There are probably more recent articles out there but thought these might be useful to start.

First one provides a little information about protocol handlers and how to change. The other has more information about setting default browser in win11. Seems a pain. lol Hope these help you do whatever you are looking to do! :smiley:

Brave 1.30 supports Microsoft Edge’s protocol on Windows to become the true default browser on Windows 10 and 11

How to change your default browser in Windows 11

Thanks. This is helpful. Choosing Brave as default browser leaves some file types orphaned to Edge. Some setting for Edge cannot be changed apparently but I was able to reset these to Brave and we’ll see what happens.

in Settings Apps>Microsoft Edge I changed default to Brave for the following file types


1 Like

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.