How to remove Brave Lens?

Hello, I wish to know if there’s an option to remove the newly added brave lens when searching from an image. The only real reason I’m using Brave and not Chrome, is because Brave wasn’t forcing into me this useless and annoying Google Lens feature, so I could just right click on an image and search a higher resolution for it. But now, even on Brave, I have no choice anymore. All I want to know is if there’s an option to remove lens and go back to the old search for image on google method. Thanks.

6 Likes

Yep, somebody better figure this out because I want to use Google Reverse Image Search

4 Likes

Seconding this after a google search for this string, because this change was plain unnecessary and just cringe. I rely on this feature daily in my browsing. I was thinking it might be a google change, but, nope. Opening up my chrome install and right-clicking on an image, “Search Google for image” is still there, plain as day.

3 Likes

Hi all and welcome to the community. :slightly_smiling_face:

Have you tried disabling Lens in brave://flags? I don’t know what the Default mode is or what impact it will have (if any) if you disable. Just an option you might try to see if it works and returns state to previous settings.

What is this brave lens thing? I cannot find it. I am on the latest build.

I disabled this and it doesn’t remove it from the context menu.

It’s in the context menu where search image with Google used to be

1 Like

Anybody find a way around this yet or a trustworthy extension? This was was s super annoying change that came with the last update. I tried disabling. Didn’t resolve the problem.
Screen Shot 2022-03-02 at 3.52.42 PM

3 Likes

I’m on the latest build too, and I cannot find either Brave Lens or Search Google for Image.

Is there a setting that disables this? Am I blind?

1 Like

@chh_68 @Go-go_duck I can’t help explain. It doesn’t make sense to me.

If anyone facing the issue wants to explain via a step-by-step I would greatly appreciate it. :grin: I have other questions too that I listed below. No worries if I’m asking for too much! lol I just want to understand what the heck you are talking about.

  1. Is Brave Browser your default browser in brave://settings/GetStarted
    • if not Brave, what is it in your windows settings
  2. What is you default search engine in brave://settings/search
  3. What windows OS are you using
  4. What/Where is the “context menu” you reference, is this from an extension
  5. Have you tried in a private window/disabling extensions
  6. If chrome is your default search engine, have you tried to disable Lens there
2 Likes

Found it. It appears when you are using google search. Both of us were using some other search engine, while these guys were using google.

When you right-click on an image, the brave lens/google image thing appears.

1 Like

Hmmm, still not working for me. What I did and tell me what I need to do. :stuck_out_tongue_closed_eyes:

  1. My default search is DDG. I went to google search in an NTP, searched for an image, right clicked, and nothing.
  2. I changed my default search to Google. Repeated steps and nothing.

What am I missing!!?? lol

Edit: May be something in settings… with DDG as default browser, google search/images looks like this

When I repeated using a Test Profile that has very little setting changes and I repeated using a private window, this is what it looks likes in both instances

Still not getting anything when I right click an image though in any of those.

See

OK, so this is weird, when I opened a private window, this is what I see. The search bar is like on my default window now and doesn’t display the one I had in the previous private window… weird.

OK, if I open a private window using the test profile I get the different one. ugh.

Still no “Search image with Brave Lens” in either.

I have fixed this problem in chrome by just disabling that “enable-lense-region-search” but the same is not working on brave and I mostly use brave so how to fix it cause google lense really sucks and give less efficient results than image search.

@okok Hi and welcome to the community. :slightly_smiling_face:

@MichaelMaus Said he tried that in brave://flags and it didn’t work for him. I don’t know if he tried in chrome.

You might give it a try and see if it works for you since it worked in chrome (the below image was copied from post #4 above).

Getting the “Search image with Brave Lens” in the context menu with google search now. I left google search as my default browser, exited the browser, and when I opened it back up it started working. Now when I change my default to google search it always appears and works even if change back to a different search engine, closing browser and opening it again (it wasn’t doing that before).

1 Like
1 Like

i have tried it in brave but it doesn’t work even after relaunching the app.

1 Like

@okok OK. Wish it had worked. :disappointed_relieved:

@aman_m Cool. Wonder if this thread prompted someone to open an issue report. hahaha I think other users on reddit were posting about the same thing. I’m glad it caught the attention of someone who participates in Brave GitHub.

Take care all. Hope the issue is resolved to your satisfaction.

1 Like