How to continuously sync bookmarks between Mac and iPhone

Hi @Mattches

I just don’t understand how to continuously sync bookmarks between my Mac and iPhone.
On my iPhone there is a mobile device appearing. However, on my Mac the device list is empty.
The videos I have found on YT are too old and are not working for me.
Can anyone please assist?

Apologies for the late reply.

Once a Sync chain is established and both devices are added to the chain, Sync will be “continuous” – that is, it will automatically sync/update data across devices.

I would recommend removing both devices from the chain and starting fresh and we’ll use this thread to troubleshoot any issues. I would also recommend starting the sync chain on the opposite device you started before.

Hi, thanks for getting back.
I tried to do both, syncing from iPhone to Mac and vice versa, but without success.

When you say “without success” do you mean that no data syncs? Or that data only syncs one way? Or is it all working but the devices aren’t listed in the right spot?

When I scan the QR code with my iPhone, the device is listed.
But on my Mac no device appears.

And this is after closing/relaunching both browsers? Additionally, can you share a screenshot of the brave://sync-internals page on your macOS?

Yes, after closing and relaunching both browsers.
I have tried to use the QR code. I have also tried to make it work copying and pasting the code.
In my phone settings the mobile device is appearing. In the desktop browser no device is listed.

Thank you for the information. Going to look into this with Sync team – appreciate your patience. We should be able to get this figured out.

Can you also go to brave://version and share a screenshot of this page?

Yes, sure.

1 Like

Sorry for the long wait on this. So you appear to have an unexpected command line argument (--sync-url= that is causing the issue, but it’s unclear why exactly it’s there. Can you please try the following test:

  1. Quit Brave
  2. Launch Terminal application on your mac
  3. In the terminal, enter and run the command "/Applications/Brave Browser" --arg1
    (--arg1 means nothing, just to check that the browser was launched from the command line)
  4. Once open, return to the Brave://version page and send another screenshot of this page.

Alright. Screenshot attached.

Any news @Mattches ?

So sorry for the long wait – we’re quite busy recently.
I’d like to check and see if a certain flag is enabled:

  1. In Brave, go to brave://flags
  2. Search for a flag called #use-sync-sandbox
  3. Set the value of this flag to Disabled
  4. Relaunch the browser when prompted

After relaunching, Sync should be good to go. Please let me know if this does not work for you.

I followed your instructions and Brave is finally syncing.
Thanks so much for your efforts and help!

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.