Brave Sync V2 on iOS

I have just recently moved to brave and I am setting up sync between my Linux machine and iphone but after waiting for sometime syncing doesn’t seem to work. Is there a way to debug this?

Note that at this time only bookmarks data will sync for iOS devices. Can you elaborate a bit on what exactly is happening? Do you see both devices on the Sync chain when you go to Settings --> Sync?

I am able to see my desktop device on the sync chain from my iPhone, but the bookmarks from my desktop aren’t being added to my iPhone.

Do you see both devices when look at the Sync menu on your iOS device? Also, can you confirm that you have the bookmarks data type selected to be synced:

Yes I can see both devices on my iPhone and I have also selected bookmarks in my sync settings

If you’ve done all the above and also closed/relaunched the browser (on both devices) then something else fishy is going on. If you haven’t relaunched the browser on your devices, do so now. Then if it doesn’t work, can you please, in your desktop browser, go to brave://sync-internals and send me a screenshot of the page so I can take a closer look?

Here is the output from sync-internals:

Here is a more recent output, seems like auth is failing:

I connected my other computer and sync worked on that. Seems like iOS is the only one not syncing.

I’ve reached out to Sync team about the issue. In the meantime, I would try removing the iOS device from the chain, then re-adding it.

Removing the iOS device didn’t help. One thing that is interesting is I can only remove the iOS device from my iPhone and not on the other computers. This might be one of the issues. I can maybe try adding using the passphrase instead of the QR code

Using the pass phrase instead of the QR code made no difference.

1 Like

Thank you for trying – I’ll be sure to reply when I hear back from Sync team.

1 Like

It looks like the history has synced and bookmarks appear when I’m searching but I can’t see the actual bookmarks in the bookmarks screen on the iOS app.

Interesting – have you tried restarting your iOS device? Do you see the bookmarks on the other device on the chain?

I’ve tried resetting the iOS device and that doesn’t seem to change things. I can also see the bookmarks on all my other devices.

Ok looks like it properly synced now. Appreciate the quick responses on here

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.