Horizontal scrolling still doesn't work (logitech)

Forgive me, but I could not find a way to re-open an existing issue on this here:

Description of Issue
Identical to the existing issue linked above, where horizontal scrolling does not work with a Logitech mouse.

Following the directions in the marked answer (disabling Device Recognition and Hardware Acceleration) initially fixes the issue, but upon restarting brave horizontal scrolling breaks again.

Any Brave developers have a logitech mouse they can test with? The previous thread implies horizontal scrolling on trackpads work fine, but Logitech devices fail for some reason.

Hi @bguscott, welcome to Community!

I noticed you said:

Do you happen to have clearBrowserData on exit enabled?

Also, When you’re disabling Device Recognition are you doing it through the settings or from the Shields icon next to the address bar?

Thanks for the reply, Aa-ron!

I do not have clearBrowserData on exit enabled.

I’ve disabled Device Recognition from the settings and not the Shields icon. I’ve set it to “Allow all”.

When I try horizontal scrolling on a site it initially works (for a split second) but then stops, implying that it’s still getting blocked.

To confirm, I also have hardware acceleration disabled.

Are there any logs I can enable/send that would be of use?

Can you provide an example site for us to test the horizontal scrolling?

Google sheets is a good example.

Otherwise, search for “horizontal scroll test” could work too. Every web site with a horizontal scroll doesn’t work.

Does the scroll bar appear and you’re just unable to move left to right, or does the bar not appear at all?
Also, does horizontal scroll function when holding the Shift key?

The scroll bar appears as it should, and horizontal scrolling (using the horizontal scroll wheel) actually works for a split second before it seems to get “blocked”.

The horizontal scroll bar never disappears and is still usable via clicking - just the horizontal scroll wheel fails.

Holding shift doesn’t appear to help. Disabling Shields also doesn’t help.

Bump. Can I enable any debug logging to look further into what’s blocking the action?

I don’t have my Logitech trackball handy, but trying with a M325 mouse, horizontal scrolling (by holding Shift and using scroll wheel) works fine in Brave 1.4.95 Chromium: 80.0.3987.122 (Official Build) (64-bit) on Windows 10 OS Version 1909 (Build 18363.592). I gather your device has an extra wheel just for horizontal scrolling?

Do you have the Logitech software installed?

That’s correct, it only doesn’t work with the dedicated Logitech horizontal scroll wheel. It’s been this way for a number of Brave builds (it never worked). Issue is replicated on other PCs that have Brave installed.

Using shift+scroll on the mouse with the horizontal scroll wheel works fine.

I have another Logitech mouse with the normal scroll wheel, and clicking it sideways for horizontal scrolling works just fine.

Firefox and Chrome both work. I’m using the Logitech Options software to manage the mouse.

EDIT: To clarify, using the horizontal scroll wheel works for a brief moment (maybe 100ms) before it seems to get “blocked”, and then no longer allows any movement. Shields are disabled and 3rd party device recognition is allowed.

The horizontal scrolling seems to work for ~100ms on each new web page before being blocked. Refreshing the web page it stays blocked (doesn’t work for the ~100ms) but re-opening in a new tab it works briefly again before getting blocked.

@bguscott,
I’ve reached out to the team for more info – I think it’s just a matter of someone having the right type of mouse to test with. Appreciate your patience.

Not a problem. Please feel free to reach out to me directly if I can assist with delivering any logs or other potentially useful information.

Interesting. Uninstalling “Logitech Options” seems to fix horizontal scrolling - it works as it should now!

If anyone else has a Logitech mouse with a horizontal scroll wheel (e.g., MX Master) and it stops working within Brave, as a workaround you can uninstall Logitech Options to make it work again.

Same here. I followed this and your last thread and had the same results. I now uninstalled the logitech software and the horizontal scroll wheel works again. Hopefully this can be fixed because I was using the “mouse gestures” which don’t work without the software.