Help! Cant open .pdf saved in brave! URGENT!


I have recently started using Brave, a week ago maybe, and its been good, but now ive got a serious problem.

I just spent an entire night searhing the internet for certain researches and downloading .pdf files for my presentation wich is today. However, now i see i cant open those files with acrobat reader, and if i open them with brave or chrome theyre all blank. I also noticed they all are named like “filename.pdf.html” .

Acrobat offers to convert them to pdf, but when he does they are all white pages.

Files are about 20mb each, so there should be something in them rather than blank pages.

I saved them by opening them with brave browser, they appeared ok, i right clicked and pressed “save as” , seeing now i have beed saving them as websites, as this is the only available option under “save as” and since im in a hurry i just did what i usually did on chrome or firefox, not even thinking about it since that simplest method worked for past 20 years on various browsers.

Please can someone help me, i cant search again for all those .pdfs , i need to open them somehow!

And is there an option on Brave to save .pdf? cause if there isnt, whats the point???

Thanks in advance

Thanks for reaching out! It’s urgent so lets just jump into it:
First thing is to check this option found in Settings --> Advanced --> Site Settings --> PDF Documents and ensure that this option is enabled. This is the default so if it’s already enabled, then disable it.
Now visit the site where you’re getting the PDF file from and click to download or open. It should either download or open directly in browser. If it opens in browser, are you able to click here and save as PDF?:


Thanks for the quick reply!

The option was disabled.

When i enable it, i cant open the .pdf file in brave, it just opens the “Save as” window, but now with the option to save it as an Adobe Acrobat document.

When i disable it again, im back to the old, can preview the file in Brave but when i go “Save as” i can only chose “Webpage, HTML only” or “Webpage, complete”.

So i guess thats it, Brave cant handle .pdfs…

i did find one solution that is to open pdf in brave, then go print, and then in print dialogue select save as pdf. And there goes my 2 seconds i supposedly saved by using Brave anyway. Considering i work with pdfs alot im definetly not planning on doing that every time, simple right click > Save As worked fine since like, 2000, im not adding a step 20 years later…

And also since i spent entire night downloading files that are now trash, i got pretty angry with Brave…

So goodbye everybody, im back to good old fox…

Spontaneous conversion of PDF files to html sometimes happens on Chromium based browsers if you leave the tab open for too long and if you have multiple tabs of PDFs open. I’d bet that that’s what happened. A refresh usually fixes the issue. So I guess that’s something that the developers could keep an eye out for.

Also, are you sure that the PDFs weren’t copyright protected in any way, in my experience that sometimes causes them to save as html files regardless of the browser you’re using.

I just tried downloading a PDF with “right click -> save” and it worked perfectly fine.

1 Like


One .pdf open at the time, multiple open at the time, waited 1 second, waited 10 minutes, all non copyright protected pdfs, its always the same in Brave - only option on right click > save as is to save it as a Webpage.

Fact that this always worked perfectly fine in firefox and chrome, and even internet explorer, clearly shows problem is in Brave, not the .pdf document.

I have just tried the same thing at work where i also installed Brave, and its the same thing, right click save as > Webpage is the only option. I have windows 7 at home and windows 10 at work.

Going with the method of print > save as .pdf is not a viable option, since i have to wait for a file to be “prepared for printing”, then wait for “loading print preview” , and have 1 more step in the whole process, not worth it, specially for someone working within academic community dealing with pdfs all the time.

I have also tried it at co workers macbook pro 15 touchbar, and also it doesnt work, only can save as webpage and then cannot open it with adobe acrobat and shows blank pages when reopened in Brave…

So i would definetly say the problem is in Brave browser, since exact same files can be saved perfectly fine on windows 7, 10, and MacOS on chrome, firefox and internet explorer, but not with Brave, in any of those configurations.

I hope you understand this is a serious issue, and hope you work to fix this.

Tanks for your time anyway!


1 Like

Perhaps I’m confused

:point_up: This seems to be the real problem here.
On my Win10 machine, if I save any .pdf file using the context menu (right-click --> Save as...), the browser wants to save the file as a webpage/HTML Only – as you describe. If I hit the download button:

The browser offers to save the file as .pdf.


That’s what it should be doing. Your default .pdf file viewer is likely set to Adobe Acrobat – correct? Save the file and observe the file type/properties of the document:

This topic was automatically closed after 30 days. New replies are no longer allowed.