Google blocking certain API's from Chromium

I was just wondering has anyone heard with Google Blocking certain API’s so as third party Browsers are not able to use them will affect Brave?

See this thread: