Gliffy Diagrams not loading

windows
bug

#1

Description of the issue:

Gliffy Diagrams on Confluence (Atlassian’s Wiki) doesn’t load in Brave

Steps to Reproduce (add as many as necessary): 1. 2. 3.

  1. Launch Brave, navigate to any atlassian confluence page with embedded Gliffy Diagram in it
  2. Disable Brave Sheilds
  3. Gliffy diagram shows a broken image thumbnail and the loading gif keeps on going forever.

Actual Result (gifs and screenshots are welcome!):


Left half is Firefox and the right half is Brave

Expected result:
The above screenshot compares Firefox, Brave - Expected Result: Load the image.

Reproduces how often:
100% of time

Brave Version(about:brave):
Version 0.56.15 Chromium: 70.0.3538.110 (Official Build) (64-bit)
on Windows 10 Pro build 17763

Reproducible on current live release (yes/no):
yes

Additional Information:


#2

@bravepc,
What happens when you try to load the page with Shields Up?


#3

Its the same behaviour. Shields were brought down due of the said behaviour.


#4

This may sound strange, but can you try visiting the site with the graph on it in a Private window? I have a feeling there’s some background shenanigans with Brave’s protections happening.

Let me know the results.


#5

Hi, That seem to work! Opened the same page in a private window with shields down and diagram loaded instantly.


#6

Yeah, I think that this may be the issue:


Not super convenient but at least its on the board with high priority. You’ll likely see this fixed in an update in the near future.

I’d suggest using Private Windows for this task for now or, you can download the Beta or Developer builds of Brave and see if the issue presents the same way.