Getting Evernote Web Clipper to work?

Description of the issue:

I am not able to get the Evernote Web Clipper to work.

Steps to Reproduce (add as many as necessary): 1. 2. 3.

Using Web Clipper on Firefox is pretty straightforward, when I am on a page that I want to save all or part of I simply click on the Web Clipper icon and am then prompted to select what I wish to save and which Evernote Folder to file it in.

When I try to invoke Evernote’s Web Clipper on Brave this is what happens.

  1. Click on Web Clipper icon in browser bar
  2. An Evernote window flashes briefly then disappears
  3. Smaller Evernote notification appears with the following message, “Evernote Web Clipper uses cookies to identify your account. Check your browser settings to make sure third-party cookies are accepted from Evernote.”
  4. Nothing is saved

Actual Result (gifs and screenshots are welcome!):

Expected result:

Web Clipper saves to Evernote

Reproduces how often:


Operating System and Brave Version(See the About Brave page in the main menu):

MacOS Mojave 10.14.4

Brave Version 0.63.48 Chromium: 74.0.3729.108 (Official Build) (64-bit)

Additional Information:

My experience is that you need to allow javascript on the site you’re trying to clip from for the Evernote webclipper (which uses javascript) to work properly. (You can always turn javascript off again. Click the lock at the extreme left of the address bar, and select from the JavaScript dropdown.)

1 Like

This seems to be working on my end – did you login to the Evernote web page that launched after the extension installed? I think if you authenticate into the webpage the extension uses the same data to find your account.
Try visiting Evernote’s website and signing in first.

1 Like

Thanks Archie! I allowed Javascript with Evernote and it’s still not working. Very odd.

Thanks Mattches - I did go to Evernote and login and I’m still getting the message “Evernote Web Clipper uses cookies to identify your account. Check your browser settings to make sure third-party cookies are accepted from Evernote.” I also disabled my VPN briefly which had no effect. Glad to see it’s working for you!

When I try and use the Web Clipper I see two windows pop up, then disappear, in quick succession before I get the “Evernote Web Clipper uses cookies…” popover message. It’s trying to work!

1 Like

Allowing scripts seems to work as well – however, it looks like Scripts should be allowed already by default (as per your default Shields settings). When you visit [any site] for the first time, are Scripts blocked or allowed by default?

Hey Mattches, yeah scripts are not blocked and I’ve futzed with every setting I can find that might make a difference. Basically Evernote can control my computer through the Web Clipper at this point! Here’s what my Shields Settings looks like now.


And yet I still get this message:


Very odd. The fact that it works for you is all the more baffling. Are you on a Mac running Mojave?

Thanks for your assistance!

Note that the Shield settings you’re adjusting are the Default Shields settings. These are applied “by default” to any site who’s settings have not been adjusted.

Try the following:

  1. Uninstall Evernote WC (temporarily) extension
  2. Visit and click the “lock” icon in the address bar image
  3. Then select, Site Settings --> Reset Clear data and Reset Permissions. This should start us with a clean slate with respect to Evernote.
  4. Reinstall Evernote WC extension
  5. After install, Evernote web page should open in browser. While on this page, open your Shields panel (lion icon on right side of address bar) and set the Cookies setting to Allow all – the page should refresh.
  6. Now authenticate into your Evernote account via the web page.

After completing the above process, try to use the extension again. Let me know what you find out.

Hi Mattches, Sorry for the slow response. That didn’t fix the web clipper issue but I do have a new datapoint that seems relevant. After I did the “Reset Clear data” and “Reset Permissions” I logged back into Evernote and tried install the Web Clipper extension from a link on the Evernote site. (Note that I was logged in to Evernote) When I clicked on the “Web Clipper extension” link on the the Evernote site I got a “Log in to Evernote” prompt. It appears that the “Login state” isn’t persistent which seems like a parallel issue to the web clipper asking me to Login repeatedly. I’m happy to walk through this in detail and share logs if that would help.


This topic was automatically closed after 30 days. New replies are no longer allowed.