Fonts on webpage show as random letters and symbols

I am so frustrated, I about to discontinue using BRAVE because I cannot read my webpages! Almost all of them have this problem. I turned off the shields and nothing changed. I reset settings. I turned on and off all kinds of settings. I have no custom fonts installed. Chrome and Safari do not have this issue. I am on MAC OS Big Sur. Any suggestions? I will attach an example image.

@SPG can you check your fonts in Brave? Your issue seems similar to Brave shows random text in some websites - #5 by swo0sh if you want to look through that topic.

I looked at this help page and tried the changes; it did not fix the font issue. I have tried using TIMES and TIMES New Roman.

BTW - I did all these too and nothing worked …

  1. Can you go back to and install on top of your current version? To be clear, don’t uninstall anything. The purpose of this is just to patch anything that might be missing or corrupt in your current Brave.
  2. Check brave://components and update everything there.
  3. Check out your settings at brave://settings/fonts. If you change fonts, does it resolve?

@SPG thanks for checking. If not too much trouble, would you mind trying each step below? Try to go in order and only test one at a time. What will be helpful to know is if the issue persists or goes away in each step.

  1. Open in Private window.

  2. Add a new profile. This is Hamburger Menu imageMore ToolsAdd new profile. Don’t change settings or add extensions. This just creates a second profile you can use to test.

  3. Look to see if you changed anything at brave://flags.

  4. Disable Shields (doubt this is it, but making sure not to skip it)

  5. Try to install Brave on top of your current version and see if it fixes it. Don’t uninstall, just download on top of the current. This will manually patch anything that might be corrupt or missing. (seems you replied as I was writing this)

  6. Try on Brave Beta or Brave Nightly.

  7. Lastly…if issue still persists despite all of the above, can you test on Chrome just to see if it happens there? It will help identify if it’s a Brave only issue or Chromium problem.

And yeah, from your screenshot I can surmise you’re using Brave 1.63.162. And by saying Big Sur, I know it’s Mac 11, though not sure which of the Big Sur updates you’re using. (Those are often helpful to know, but at least have vague idea)

So I did all suggestions nothing changed. BUT! I tried Chrome before and it was normal - NOW, not normal! See attached CHROME image beow:

I see there is an OS update; I am doing that now to see if there are any changes, but it needs a few hours.

1 Like

Thanks greatly for checking it all out. I’ll be looking forward to hearing back on status after the OS update. Otherwise it might just mean it’s a potential upstream issue with chromium browsers and we’ll have to try to pass that along to see if a cause and solution can be found.

That took a while! Nope, no change … :sob:

Okay, so will tag in @Mattches to see if he can walk through any steps or might know what’s going on

Thank you. I tried Safari and there are no font issues there.
I am now using macOS Monterey Vs 12.7.3

I have fixed it!

MAC: Go to the Font Book app, then File > Restore Standard Fonts and shutdown, turn back on.
I must have had a corrupt font from a recent project that was causing all these issues!


This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.