Fix for Ctrl+A not working properly on History Page

Have you Noticed Ctrl+A won’t work properly While you choose this option to delete all of the history(All time) only for a Specific site ?

Initially, Brave/Chromium will report like it has found 150 matches but this report is false and sometimes Ctrl+A won’t work while used with this host domain search

So, a way to have the history deleted properly for a specific website is by performing this host domain search(which can be done simply choosing “more from this site” option found in the history page’s 3 dot overflow menu of the website history link of any specific website which you want to delete or by manually typing in the website name which you want to delete in the history search bar (host:www.sitename)

once entered the host:www.sitename or choosing "more from this site"option, keep scrolling all the way down until the infinite scroll gets ended…

once the scroll gets ended, use ctrl+A to select all items(Ctrl+A will work now) and press the delete button … Now, the history of that specific website will be fully deleted.

See, At first, Brave reported it has found 150 matches…
But after performing this move, it claims there are 1400 links

This is the proper way to have the history deleted manually for a specific website.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.