Error link to gemini wallet

Briefly describe your issue:

What Operating System and Brave version are you using (Menu --> About Brave)?
Version 1.36.119 Chromium: 99.0.4844.83 (Official Build) (64-bit)

**Is your browser wallet currently verified? (yes/no)**yes

**What date did you verify your wallet?**april 15

**Have you been able to successfully receive payments in the past?**no

**Are you using a VPN? (yes/no)**no

**Are you in a supported region (see here for list of supported regions)?**yes

Too many attempts still cant process to link my gemini wallet. Even do clear cache and cookies.