DNS over HTTPS doesn't work anymore on Brave Desktop

Description of the issue: Until yesterday I used a custom DNS in Brave but then I noticed that the requests weren’t resolved anymore. I checked the Brave settings > Security and apparently the Secure DNS option is not activatable anymore. Instead it is saying now, that this setting is disabled for managed browsers. But in fact nobody else is managing it than me, cause it is my private PC and not managed any other person or Institution. I tried to re-install the browser but it didn’t resolve the issue.I tested it and DNS over HTTPS worked on other Chromium Desktop apps and also on Brave Android.
Any idea how to get the DoH back to working? Any hints highly appreciated.

Brave Version( check About Brave):
Version 1.40.105 Chromium: 103.0.5060.53

Additional Information: Windows 11

Hi

@Tiak To fix Brave Browser Managed by your Organization follow the steps:

  1. Hold windows button+R and enter regedit
  2. First Save your registry (in case you need later) by opening file+export
  3. Go to and delete the following entries

HKEY_LOCAL_MACHINE\SOFTWARE\Policies\brave
and
HKEY_CURRENT_USER\SOFTWARE\Policies\chrome

Taken from https://www.joshualowcock.com/guide/fix-chrome-is-managed-by-your-organization-in-3-steps/

  1. Restart PC

PS. I tried this a couple of times before and it worked.

Thank you for the reply!

I opened regedit and followed the steps, but unfortunately I couldn’t find the entries in the chrome and brave directories. Anything else I could try to solve this? I do not know what to do :confused:

Btw also checked brave://management and it says the browser does not get managed by a company or organization.

What version of Windows you have?

Windows 11 Home
OS Build: 22000.739
Version: 21H2
@CerealLover

Does this help?

Hi

Did you install antimalware, a plugin or extensions before? From what I know, this issue occurs because of the latter or may be an infection.

IN my case, when I install an antimalware called spywareblaster and Brave become “managed by your organization”. When I open brave://policy/, I get this

In your case, what do you see when you open brave://policy/ ?

1 Like

Hey!

I got a couple of extensions installed in Brave but they do not seem to have an effect on policies.
As you see in the image below, no polices set in my browser. Though I didn’t checked the policy site immediately after the issue appeared. I first did a couple of re-installations of the Brave browser and the extensions before finding the policies site on some other brave community posts of users with a similar issue. The results were identical with what you see in the screenshot.

I am really at a loss as to what else I can try with this problem, cause I am not really an expert. In any case, thanks so far for the assistance!


Anyone here got an idea what else can I try to fix this issue with the disabled Secure DNS (DoH)?

Do you have anything indicating being managed by an organization at the bottom of the main menu? e.g., here:
image

If so, do you have Chrome installed on the same PC? And if so, does it show the same?

Even though the issue doesn’t seem connected to the extensions, did you try disabling them all – relaunching the browser – and checking again?

Is any antivirus or other security software installed?

Hey, thanks for the response!

I checked Brave browser again if it is managed by an organization, but I it seems like it isn’t, I couldn’t find any message and also checked brave://management (see first screenshot).

And regarding Chrome, I didn’t have it installed but I installed it to see if I get the same issue there and yes, same issue appears in Chrome (see screenshot 2). It could be related to Chromium somehow, the only thing that was strange to me was, that in Vivaldi browser (also Chromium) setting Secure DNS is working perfectly, without the disabled setting (see Screenshot 3).

I also tried deactivating all extensions in Brave and relaunching it, but that had no effect. It still said it was disabled in managed browsers.

Furthermore I do not have any security or antivirus installed except of the pre-installed Windows Security / Defender.

This is all very irritating and I do not know how to possibly solve it :confused:



These are the same specifications as me. DNS over HTTPS doesn’t work although my browser is not managed. This problem happened either after changing the default browser to Microsoft Edge and back to Brave or after the last Brave update. Also, now it does not automatically check for updates when I open brave://settings/help.

An error occurred while checking for updates: Update check failed to start (error code 3: 0x80080005 – system level). This is the warning message.

I use Version 1.40.105 Chromium: 103.0.5060.53 (Official Build) (64-bit) at Windows 10.

And regarding Edge Browser, DNS over HTTPS neither worked there. On the Edge browser said though that it was managed by an organization. This was fixed by the regedit solution @CerealLover suggested above. But as mentioned I cannot apply that fix for Brave as mentioned earlier cause it doesn’t say it is managed and also the policies directories do not exist for Brave neither for the Chrome browser which I installed testwise.

It might be related to a bug or something. Anyways it just goes is beyond my knowledge and understanding to fix myself at the moment. Maybe I should ask the same question of this issue in Googles community for Chrome.

Hi @DNSoverHTTPS-enjoyer - that sounds like it might be a different issue, I would recommend starting a new thread about it (after searching the forum for that error code).

@Tiak , main reason I asked about Chrome is, I wonder if there may be malware on your computer that is targeting the Chrome browser, and Brave is being affected by it as well.

Defender is good, but I would recommend running a full scan, and maybe even an Offline scan, just so we can more-or-less rule that out.

Otherwise:

Did the computer previously (or currently) belong to a company who managed the Windows configuration?

Is anything set in brave://flags ? (Anything with a non-default setting will be sorted to the top, and will have a blue dot next to it.)

Aside from that nothing is jumping immediately to mind but I’ll see if I can come up with any other ideas.

@Tiak , @DNSoverHTTPS-enjoyer

Clear DNS cache:

Using a Brave Browser > New Window, go to: brave://net-internals/#dns

  • Click on: Clear host cache

Close idle sockets and Flush socket pools:

Go to: brave://net-internals/#socket

  • Click on: Close idle sockets
  • Click on: Flush socket pools

Exit / Quit Brave Browser.
Restart your computing device.

Notes re what are:

DNS cache:

Socket pool:

With pooling, instead of closing a connection after it is used, we can keep it idle while it waits to handle another request. This saves the resources required to create a new connection.

Very easy, plain website that simply displays DNS status:

Also:

Hey @JimB1.

Tried both, no malware or virus detected.

No. It is my private notebook. It was new when I bought it and not related to any company I am working for.

I do not think so. When searching up ‘DNS’, I could only find the following (see screenshot). I have not changed anything of that after I re-installed.

You still got any idea what else I can try here?

Thanks in advance,

Tiak

Hey @289wk, thanks for the response !

I tried clearing cache and restarting everything, but unfortunately it did not resolve the issue. HTTPS over DNS is still disabled in Brave and I can’t change that.

Also the NextDNS testpage reponses the following. I guess that is normal if the secure DNS isn’t enabled (?)
image

You got any idea what else I can try?

Thanks in advance,

Tiak

@Tiak

The NextDNS.io response page is that basic, as you see it.

I double-checked, and found that the ‘User secure DNS’ setting still works, and DNS over HTTPS can be Enabled / Disabled.

The ‘User secure DNS’ setting info, is stored within the ‘Local State’ file:

  • / . . . /BraveSoftware/Brave-Browser/Local State

Enabled:

Screen Shot 2022-06-24 at 8.56.45 PM

Disabled:

Screen Shot 2022-06-24 at 8.56.27 PM

You might examine the file, but I would not edit the file - that editing could really mess up your Brave Browser installation.

By the way, DNS over HTTPS (Use secure DNS) may not work, when your computing device is connecting over some network that summarily is able to determine the DNS server(s) for your Internet activity.

Such a network would be found at many locations and also, when using one of the cellular services.

Hey @289wk I personally do not know what to do then to fix it. As you see above that problem also exists on my device for another Chromium, the Google Chrome browser, but not Vivaldi or Edge, where I can enable DoH without any difficulties.

This issue is beyond my knowledge and understanding, i tried every troubleshooting you guys suggested, but the issue is still there :frowning:

@Tiak

Did you examine the ‘Local State’ file, to see if the ENABLED (automatic) status for dns_over_https is set?

In a Windows OS command prompt window, enter:

  • nslookup -type=soa brave.com

In a Brave Browser > New Private Window, go to:

In a Brave Browser > New Private Window, go to:

Use the ‘DNS Check’ tool, as follows:

Screen Shot 2022-06-24 at 9.18.18 PM

What are your results?

The MXToolBox results - showing the [DNS] name servers for brave.com :

Screen Shot 2022-06-24 at 9.23.52 PM

Do you get such a result?


I do