Dev Tools Dark Mode Not Working

Description of the issue:
Developer tools dark mode not switching on

Steps to Reproduce (add as many as necessary)
Open developer tools - click on settings gear icon in top right-hand corner - Appereance > Theme: > Dark

Actual Result (gifs and screenshots are welcome!):
There is no result - the dev tool console remains in light mode - even after restart and reloading browser

Expected result:
it should just go into dark mode

Reproduces how often:
every single time

Operating System and Brave Version(See the About Brave page in the main menu):
Windows 10 64-bit - Brave Version 1.32.106 Chromium: 96.0.4664.45 (Official Build) (64-bit)

Additional Information:
Dark mode was working fine until the latest update I think

2 Likes

Hello @Rich777

i just tried it but on linux and it work fine
could you create new profile and see if that new profile work fine or not

if it work then maybe an extension effect that could you disable all extension and see if it work fine or not

I am unable to run Dark Mode on Dev Tools.
I am on

  • Mac Os Big Sur 11.6
  • Version 1.32.106 Chromium: 96.0.4664.45 (Official Build) (x86_64)

Please fix this!

Hello @jackjack123

for me to make the dark mode work i have to go to brave://settings/appearance then change Brave colors to dark
then refresh the page or reopen the dev tool again
does that work with you?

1 Like

Hey thanks for the tip.
Yes that works, but then my entire Brave browser is in dark mode…

I prefer just the dev tools in Dark mode. Anyway, no big deal … I can live with it all in Dark mode :dark_sunglasses:

Thanks!

Oh that worked nicely - great tip, thanks.

(Yes, like @jackjack123 I prefer only Dev tools in dark mode, but it’s a nice work around.)

1 Like

Is the Brave dev team aware of this and able to make the fix for the next release?

@jackjack123 @Rich777 you very welcome i do not know if they know that the dev them can not get different theme than the browser theme so hope on of the team check this post and fix it

I have the same issue. Also I think the issue is bigger than just dark mode in dev tools. There are more settings which won’t save. For example panel layout won’t save. It automatically reverts back to ‘auto’.

Just replying here hoping the brave team will check this post.

edit: version info
Mac OS 12.0.1
Brave: [Version 1.32.106 Chromium: 96.0.4664.45 (Official Build) (x86_64)]

I am having same issue of dark mode not saving. Even after reloading browser as it suggest. Not saving. I am on Windows 10.

Just recently switched over. So far like Brave. Hoping things like this get resolved quickly.

Keep up the good work Brave!