Darken websites missing

Description of the issue:
Normally there is a “darken websites” checkbox in Appearance > Theme settings but the latest update removed it. This has forced all websites to remain darkened even when light theme is selected.

How can this issue be reproduced?

  1. Go to Settings > Appearance > Themes > select Light
  2. Go to theverge.com and click any article
  3. Article is darkened

Expected result:
Websites should be in light mode when Light theme is selected.

Brave Version( check About Brave):
Brave 1.11.105, Chromium 84.0.4147.105

Mobile Device details
OnePlus 5T running Android 10

Additional Information:
The flag #enable-force-dark in chrome://flags is ignored regardless of selecting enabled or disabled.

3 Likes

that’s not not always true

for example go to twitter and then change your theme from light to dark you will find the site respect that change it again from dark to light and you see it work fine

but one like verge does not
to make it work you have to clear your cache each time after you change your theme so the verge check your theme each time you visit it which is not good way
it’s issue with the website not brave
website should make code that keep running to monitor any change of your theme

hope that help and have a nice day

I am not referring to a website’s theme that they let you choose. I am referring to the Darken Websites toggle in Brave settings in Appearance > Theme.

Normally there is a checkbox for Darken Websites when selecting Dark theme in Brave settings that forces all websites to dark mode.

This checkbox is now gone and it should still be there.

2 Likes

i understand what you mean but changing the theme in appearance does not make it change in website the website need to do some work updating their code to make it work also

as i told you go to twitter and then go to the brave theme setting and change it from dark to light and you will see twitter update it’s look change it back from light to dark and twitter will update it’s look even without refresh the twitter page

so it’s not just browser work both browser and site should apply some change to make it work

hope that make it clear and please go to twitter and try what i mentioned and you will see it work you do not need to login or having account just explore it

have a nice day

Twitter is dark no matter what theme I pick. That’s what I mean by the Darken Websites checkbox. The value must be stuck because it was taken away.

Please add the checkbox back Brave! It’s really nice because I can set the Brave theme to System Default, have an app autoswitch the system theme to Light/Dark based on the time of day, and all websites are dark even if they don’t have an officially supported dark mode.

are you sure you are not logged in twitter and changed twitter preference ?

for me i did not logged in and it change as i change brave theme and without refresh twiiter

I did log into Twitter to show that it doesn’t matter which of their built-in themes I select, their website is always dark. I’ve tried both Light and Dark themes in Brave settings and the results are the same.

Are you using an Android phone? Do you see the Darken Websites checkbox when you go to Appearance > Theme and select Dark?

i did not logged that why i asked to do

clear your cache if you do not mind then open twitter without logging try to go to https://twitter.com/brave this the brave official twitter page and then change the brave them and see if it reflect on twitter or not

I logged out of Twitter, cleared my cache in Brave settings, navigated to twitter.com/brave, toggled Brace’s theme between light and dark, and Twitter is still dark.

Are you a Brave dev or have any contact with them?

Removing the Darken Websites checkbox from settings is clearly a bug and seems like a simple fix to add it back.

1 Like

idk why it does not work

i am just a user like you

i will ask @Mattches to help you with that one he is brave team member

hope it get fixed soon and have a nice day

2 Likes

@runswithjedi,
Can you confirm with me whether or not you specifically enabled a flag that forced that checkbox to appear? I personally have never seen such a check box. Further, do you have any flags enabled at this time?

1 Like

I did not enable any flags to get the checkbox to appear. It was there when I first downloaded Brave about 6 months ago. The most recent update seems to be the one that removed it.

I had #omnibox-assistant-voice-search enabled but disabling it and relaunching didn’t do anything.

1 Like

I can confirm I also had that option in the older versions of Brave. It was so convenient, once you check the checkbox, all web contents get darkened automatically. I have been downloading older versions looking for it but haven’t found the version that supported it yet.

2 Likes

While I’m agree with @Mattches, as there’s no option for that available in Brave for Android, as far as I’m aware of, unless it’s enabled via flags,

we do have a request logged to add the option to the Android version.

1 Like

It’s also ignoring the flag for me. So if I set #enable-force-dark to disabled, everything is still forced to dark mode.

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.