Claim button doesn't work if you hide the Brave Rewards button

Title says it all. Here’s how to reproduce:
1 - Go to brave://settings/appearance
2 - Enable “Hide Brave Rewards button”

Windows version: Version 21H1 (Build 19043.1348)
Brave version: 1.31.91 Chromium: 95.0.4638.69 (Official Build) (64-bit)

To fix it, I had to disable this same option. I “found” this solution here: Can't claim brave rewards (claim button doesn't work) - #6 by lenus