Claim Rewards Button not appearing

Briefly describe your issue: When navigating to the Brave Rewards tab, the Claim Rewards button does not appear. This is an issue, because the payout status is showing as complete.

What Operating System and Brave version are you using ( Menu --> About Brave )?
Windows 10 - 64bit

Version 1.32.106 Chromium: 96.0.4664.45 (Official Build) (64-bit)

Is your browser wallet currently verified? (yes/no)
No

What date did you verify your wallet?

N/A

Have you been able to successfully receive payments in the past?

Yes

Are you using a VPN? (yes/no)

No

Are you in a supported region (see here for list of supported regions)?

Yes

Does your device pass the SafteyNet check (Android only)?

N/A

Have you manually turned off Auto-contribute on all of your devices linked to Uphold??

Yes

@steeven I’m really confused on why I, and many others haven’t received our payment. I haven’t even seen the claim rewards button yet for October’s payment, and the silence from the Brave team’s end is worrying. Can I get some clarification from you guys?

Hi @jadedcloud, sure thing. We’re actively replying and looking into reports, I’m clear on what you mean by silence. I’ll need your wallet information in order to investigate your issue. Please send the following information in a DM.

  • Copy/paste your Wallet ID (found on brave://rewards-internals)
  • Your OS and Brave version (first three lines in brave://version)
  • A screenshot of your Rewards panel in Settings --> Brave Rewards.

Thank you in advance!

Hey @steeven

I sent you a DM containing that information last week. I haven’t heard anything back, and my issue is still going on. Are there any next steps I need to perform? Or am I missing something? Any information will be much appreciated.