Captcha back with a vengence

Brave search is unusable once again with the constant captchas. Please at least add a decent search engine option like yandex or searx so I can type a search in the search bar without 50 captchas a day. Nobody wants to do a captcha to search and I don’t feel like switching browsers yet again because of pit-a “features” like this.

  • Using VPN?
  • Doing on Brave browser?
  • Is this while typing through the URL bar or while actually visiting

Already exists. You can add any search engine you want.

Yes I have a VPN, using Brave browser and typing in the search bar.

How do I change it? I have tried to add those search engines. In settings I have no “add” and if I try to edit an existing search engine I cannot change the address.

@VK901 to add, you go to brave://settings/searchEngines and then scroll to Site Search

When you click on Add, it will look like you see below:


I went to add it manually, but then it auto added. So I’ll just show you what they auto added, then you can modify things like the shortcut.


the URL was

When you add it this will list under Site Search. If you use the shortcut for the search, it will search on it. Or you can hit the three dots (hamburger menu) and Make Default if you want it to be your default search engine.

Can you test if this also happens on the website search? I’m curious if one way or the other has an impact.

1 Like

Ok thanks that worked! I did not have the right url in to make it defaultable it looks like. was enough to make it work.

The brave search does only do it from the title bar. No captchas from brave search website but the same terms in the search bar with brave search as default and they all require captcha.

1 Like

@steeven and @Mattches would you guys have any ideas why that might be the case?

Confirming the exact behavior here — you are seeing captchas appear when you perform a search from the address bar while Brave Search is your default engine, is that correct? Further, you do not see the same behavior if you were to go directly to and perform the search there?

I did a few more this morning to check and I was getting the captcha on the brave search webpage as well. Not at first but if I do repeated searches the captchas start. So it does do it on both but the other day I was not getting them on the webpage and then copying the search terms into the title bar I was getting the captcha.

I ended up switching to qwant search as there aren’t captchas on that one as of now.

If you don’t mind, can you please test the behavior with your VPN connection disabled and tell me if it makes any difference? I’m not suggesting you ditch your VPN just to avoid captchas or anything, but it would be helpful to know.

Thank you

It is definitely the VPN

Thanks for checking. I know we’ve had this issue in the past but I thought it had been resolved. I will reach out to our Search folks again and see where we are at with this, as I do not think users should be punished with captchas for using a VPN and/or our search engine.

@VK901 Just was speaking to Luke Mulks on this. He asked about what countries people experiencing this are from. Just noticed that doesn’t seem to be mentioned on some of these posts. Could you advise of the following:

  • Is this still an issue for you? (If so, is it still a VPN only thing?

  • What country are you from?

  • What country’s VPN did you use?

I stopped using Brave search on my laptop at least. It still does it on my phone when I use it (have to do the slider captcha and will often fail me if it’s not exact).

I’m in the USA and typically my VPN will show Switzerland.

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.