Can't reorder tabs by dragging them

Brief summary

Can’t reorder tabs by dragging them

How can this issue be reproduced?

  1. Have multiple tabs open in a single Brave window
  2. Move mouse to the tab bar and hover over a specific tab
  3. Press the left mouse button and hold it down (mouse-down)
  4. Move the mouse within the tab bar to the left or right of other tabs
  5. Lift up on the mouse button (mouse-up)

Expected result:

The tab that the mouse was pressed down on moves to the left or right of other tabs but stays within the same window.

Actual result:

A new Brave window opens containing a single tab, the one that you tried to move. This tab is no longer present in the original Brave window.

Brave Version( check About Brave):


Version 1.34.80 Chromium: 97.0.4692.71 (Official Build) (64-bit)

Additional Information:

I am running Fedora Linux 35 with KDE. The feature in question, reordering tabs by dragging them, worked until a few days ago.

For me on Debian based distro, it works as normal.

If I drag it left or right for reordering, it stays in the same window. But, if I slightly pull the selected tab down, it creates a new window with a single tab.

The problem might be only limited to fedora and not other linux distros.

I just tried Chrome and it has the same problem as Brave. Based on your experience with Debian and my test with Chrome, I am guessing that this problem is not caused by Brave but rather by Fedora 35 or KDE. Interestingly, I tried moving a tab in Firefox and it works exactly as it’s supposed to: the tabs are reordered and a new window does not open.

Hi and welcome
it works for me as expected on Fed35 Wayland.
It is always senstive to vertical mouse movements which will detach it from the original window but I think that is to be expected.
Is it worth trying a different windowing system Wayland, or X11 which works for me on a Fed34 machine, to see what happens for you?
good luck

I am having the same problem on KDE on Arch with Xorg. When I drag the tab it pops it out into a new window and I cannot combine a tab from the window back into the original window.

I think this might be the culprit. I have not seen videos about what exactly is happening so cant say for sure.

I updated my system this morning, rebooted and tried logging in with Wayland instead of X11. Same problem.

With regards to vertical mouse movements, if I mouse down on a tab and move the cursor up, the tab detaches and I have a new window. I expect that to happen if I move the cursor down below the tab bar, but not if I move it up.

I need to try to reproduce the problem with Gnome to see if this is a Fedora issue or a KDE issue.

Thanks for continuing to update. My Fed35 is on Wayland and brave is on the same version as you with no issues. Odd that you have the same issue on Chrome but I suspect that doesn’t rule out issues in either direction.

As to the cursor up or down both detaching a tab to form a new window that is certainly my experience too and I have believed that to be normal behaviour.

For me the factor has always been to maintain the horizontal line of the tabs if you want to move a tab along the line, or in fact if you want to merge it back into a line, of tabs.

Hope you get to the bottom of this one as it is more than slightly intriguing
Gd luck

Just noticed there is a similar issue being talked about on this thread, might be worth a look
https://community.brave.com/t/moving-tabs-with-click-and-drag-is-not-working-anymore/323014/34

Brave Version:
Version 1.35.77 Chromium: 97.0.4692.71 (Official Build) beta (64-bit)

I am running in to the exact same behavior, any attempt to re-order tabs (pinned and unpinned) moves the tab to a new window. I am unable to merge tabs into existing windows.

This began for me perhaps slightly over a week ago.

I am running Manjaro KDE, Kernel (Linux 5.10.89-1-MANJARO x86_64).

I checked out the link referred to by wit5 and it contains a workaround that works for me: downgrade Brave to 1.33.106-1. On my computer running Fedora 35, I used the following command:

sudo dnf downgrade brave-browser-1.33.106-1

To see what versions of Brave are available, I ran the command “dnf --showduplicates list brave-browser”.

In the other thread, posters wrote that this is an issue with “Chromium”. I don’t know what that is, and I don’t really care, but I hope that it gets fixed soon because otherwise I will probably have to keep downgrading Brave whenever I do a system update (sudo dnf update). I normally update my system once a week.

Thanks Wit5!

2 Likes

Glad it helped :smiley: although I confess to remaining confused why some on the same distro don’t share the problem, anyway if you have a fix that works that’s great.
FYI Chromium is the web browser on which Brave is based.
Gd luck

Same issue, Debian Sid here, i3, no DE. If I click and hold a tab, it pops open a new window that can’t be merged back into the original row of tabs. Extremely annoying, if this doesn’t get fixed soon I’m going to have to use a different browser because I can’t re-order my tabs.

Ubuntu 20.04 here. Just started happening today, afaik.

Perhaps some of this will be helpful:

Brave 1.34.80 Chromium: 97.0.4692.71 (Official Build) (64-bit)
Revision adefa7837d02a07a604c1e6eff0b3a09422ab88d-refs/branch-heads/4692@{#1247}
OS Linux
JavaScript V8 9.7.106.18

$ cat /etc/os-release
NAME=“Ubuntu”
VERSION=“20.04.3 LTS (Focal Fossa)”
ID=ubuntu
ID_LIKE=debian
PRETTY_NAME=“Ubuntu 20.04.3 LTS”
VERSION_ID=“20.04”

@Mattches

(20 character limit)

Are you still seeing this issue after the update to version 1.34.81?

I just upgraded to 1.34.81 and the issue is resolved. I can again drag tabs around.

3 Likes

@davidlevner,
Thank you for confirming.

Same, just upgraded to 1.34.81 and issue with moving tabs side to side is resolved for me, as well. THANK YOU.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.