Can't Login to Websites Using Google Account Sign-In

Description of the issue:
How can this issue be reproduced?

  1. Open the account sign-in page on in the Brave Browser on MacOS
  2. Click “Continue with Google” button
  3. In the pop-up window, click the relevant Google Account
  4. The window will load the message “One moment please…” to try to connect to login to Zillow. The pop-up window closes and doesn’t successfully login to Zillow.

Expected result: Successfully login to Zillow with Google account sign-in.

Brave Version( check About Brave): Version 1.32.113 Chromium: 96.0.4664.45 (Official Build) (x86_64)

Additional Information: Doesn’t work on other websites with Google account sign-in, either. I’ve tried the steps suggested in this related post but none have worked.

Steps I’ve tried so far:

  1. Disabled the Brave shield for Zillow website and restarted browser
  2. Enabled cookies for (with third party sites setting checked) and more generally and restarted browser
  3. Enabled all cookies and restarting my browser
  4. Enabled the “Allow Google login buttons on 3rd party sites” toggle in the “Social Media Blocking” settings.

Nothing has worked yet.

Any suggestions on how to fix this? It’d be very convenient to be able to continue using Google to login to the sites on Brave instead of using a different browser or having to create a login password.

Update: I noticed that websites where the Google account sign-in loads within the same tab/page allows me to login successfully but websites that load the sign-in page in a pop-up window don’t work.

I just tested this, (testing initial sign, signout and then resign in). with default shields/privacy. Including allowing Allow Google login buttons on third party sites @sergeiwallace

I would clear the google cookies, in a seperate tab/window relogin. The refresh the zillow website and relogin there, and click on the popup.


So a general pattern that I’ve noticed is that the Google account sign-in doesn’t work when the website creates a pop-up window after clicking the Google account sign-in button. However, it does work if the website loads the Google account list within the same webpage.

Regarding your suggestion, for some reason the Zillow website behaves differently for us. In your GIF, it opens a mini-pane in the top right corner of the webpage that directly allows you to select your Google account whereas for me it loads a larger pane in the center of the Zillow homepage with multiple ways to login. When I click the “Continue with Google” button, it takes me to a pop-up window which then doesn’t work.

See screenshot below of the different interface when I click the “Sign In” button on the Zillow homepage like you did.

What do you think is causing the discrepancy in UI experience? Are you on MacOS?

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.