Can't Insert Photo in Gmail with Brave but it works in Edge

I have to switch browsers if I want to include an image in the body of an email in Gmail. It works like this.

When composing an email in gmail, you click the “insert photo” icon. Then click “upload”. Then click “choose photos to upload”. Select a .png file (or other extension). And then Brave responds with a black background and white font “There was an upload error” with a “dismiss” button/link. Every time.

Brave is up to date
Version 1.44.108 Chromium: 106.0.5249.103 (Official Build) (64-bit)

Windows 10 Pro

It works fine in Edge.

Other than switching browsers, does anyone know of a solution?


Works fine for me. Also using Windows 10.
Does it work if you drag&drop the file into the text area?
Does it work if you copy&paste the image (from an image viewer) in the test area?

Try to disable all extensions to confirm it is not any of them.
Also check in the console (F12) if you have any error when loading the gmail webpage.

1 Like

I’m also not able to reproduce this error — can insert images as well as attach images in gmail without issue on both macOS and Windows systems. Curious to know the answers to what @rodrige asked as well.

Additionally, if you can grab a screenshot of the dev tools console window when the error occurs, it could be useful in narrowing down the cause. To do this:

  1. Visit gmail
  2. Click to compose a new email
  3. Open the dev tools window (Menu --> More tools --> Dev tools, then click on the Console tab int his window)
  4. Now try to insert an image into the email
    Send a screenshot of the console window after the error occurs and hopefully it will provide some more information.
  1. Drag and drop didn’t work.
  2. Copy/paste worked!
  3. I have no extensions

Console screen shot:


I cleared the console and followed your steps and the above is the screen shot of the console.

Thank you for the information. Can you test the behavior using a guest window or in a new profile and see if you’re able to insert images into gmail using the new profile (or guest window)?

In a guest window it worked. I was able to upload a photo without copy/pasting it.

Wondering if it’s some weird caching issue. Can you try going to gmail, clicking the “lock” icon in the address bar, then Site settings —> Clear data then test again and see if this changes anything?

If not, my next suggestion would be to clear some of your browsing data — namely cached images and files by going to Settings --> History —> Clear browsing data.

I did both of those things and neither worked. I closed the gmail tab and opened a new tab but I didn’t restart Brave if that matters. Also, I got the same console error.

Very strange — the fact that it works in a guest window (and presumably a fresh profile) implies that the issue is hiding somewhere in your main profile data. Would you be wiling to try clearing data for “all time” and testing? You can probably de-select passwords and autofill data so you don’t lose that information.

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.