Can't deny all and whitelist cookies in Version 0.57.18

bug
privacy

#1

NOTE: Any “one-liner” or topics requesting support or reporting bugs that do not make an effort to include as much of this information as possible will be closed immediately. Repeatedly posting as such will get you flagged or banned.

Please try to adhere to this template when reporting bugs. If you think you don’t need to fill out every section in the template fill out as much of it as you can and please be as descriptive as possible when posting. Thank you!
<---------Delete this line and everything above before posting---------->

Description of the issue:

Steps to Reproduce (add as many as necessary): 1. 2. 3.

Actual Result (gifs and screenshots are welcome!):

Expected result:

Reproduces how often:

Brave Version(about:brave):

Reproducible on current live release (yes/no):

Additional Information:

It seems that when I’ve set Brave to block all cookies in the Cookie Control menu, and/or within the advanced Content settings menu, Brave won’t let me whitelist cookies as needed from the Cookies menu in the address bar security icon. When I set individual cookies to Allow, I get the notifications that the cookie is now allowed and I need to reload, but when I reload the page the cookie is still under Blocked.

The Cookie Control menu on the main settings, and the Content settings cookie options under the Advanced options seem to do the same thing, but I’ve played with both settings.

I’ve tried setting both Cookie Control and the Content settings option to block all, I’ve tried setting Cookie Control to allow all and the Content settings to block all, and vice versa in case one was just superseding the other, but all combinations produce the same result on multiple pages and with different cookies.

I’m running Version 0.57.18.


#2

In privacy/security --> Content Settings, what format are you entering the URLs?
For now, they must be in a particular form to work. See this issue here:


#3

I’m not entering the URL’s from the Content Settings menu, I’m trying to whitelist them from the Cookies section in security icon menu in the address bar, to the left of the URL.


#4

Sorry for my misunderstanding.
Use shields to block all cookies.
You’re correct in that you can’t whitelist individual cookies at this time. We do, however, play to implement this in Shields: