Cannot reconnect to the Uphold wallet


My Uphold wallet has been disconnected for a few days.

Every time I try to reconnect the wallet just keeps loading.

What should I do?
Thank you in advance!

I am dealing with this same issue. I haven’t been able to connect in months. I’ve tried uninstalling and re-downloading Brave. I’ve tried turning off the shield for the log-in page. I can’t figure it out and it’s quite frustrating!

@cpna Are you separately able to login to Also try to clear Site settings and Cookies on both and

@aubergineemoji Do you think you might have exceeded your quota of 4 device limits on Uphold? As every new installation would take up another slot at Uphold.

@Aman_M Unfortunately, I don’t think that’s it. I’ve only got it installed on my laptop and my phone (via the IOS app ). I did notice I can connect my wallet on the Brave IOS browser, so it seems to be isolated to the browser on my laptop. Of course that’s the one that earns the BAT rewards :slight_smile: This first became an issue back in June…

got disconected as well, updated brave now it works - but lost about 5BAT before payout. They disappeared after the update :frowning:

I tried everything I could find on the brave community site, nothing helped.
And then I just gave up.

A few days later, I decided to try connecting the wallet again and that time Uphold site loaded immediately and everything went smoothly, without turning down the shield or anything.

I had the exact same problem at the beginning of July but I was able to connect the wallet after 2-3 days. This time I thought it was the same, so at first, I’ve waited a few days again, before posting anything. However, after I couldn’t connect for like 5 days, I was worried a little and had to submit the ticket.

Now it’s disconnecting from time to time, it started doing so after that first time back in July.
And seems like that problem of Uphold not loading is happening right after rewards distribution.

Can you all post a screenshot of the error page or the page where it gets stuck in the process?

For me, it was just stuck on Uphold loading screen.

Does it working now?

Yes, for me it is working rn. And I haven’t had a similar problem since then.

Did it solved on its own or did you take any specific steps?

I have been able to connect to uphold using Braves browsers Wallet on all of my devices except for my tablet. I have 2 of the exact same tablets and I was in fact able to connect with on of them. But the one that I’m using right now I just keep getting redirected back to the beginning after each time I enter the six digit code. I have tried logging out of all the other devices and re-entering in all the information more than a dozen times over the course of about two weeks with no attempt being any better than the previous. I tried contacting Uphold first but had no success, so here I am. Thanks for reading.

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.