Cannot open dropbox file from email link if Brave is default browser

windows

#1

Description of the issue:
Cannot open a dropbox link shared via email if Brave is the default browser. Works fine if Edge is default or if link is copied and pasted in Brave url box.
Steps to Reproduce (add as many as necessary): 1. 2. 3.
Receive email with a shared file link and click “View File”. See resulting error messages below. I tried taking shields down but no help.
Actual Result (gifs and screenshots are welcome!):
Dropbox%20view%20file%20from%20email%201
Dropbox%20view%20file%20from%20email%202
Expected result:
File should load.
Reproduces how often:
Every time
Brave Version(about:brave):
Version 0.58.21 Chromium: 71.0.3578.98 (Official Build) (64-bit)
Reproducible on current live release (yes/no):
Yes
Additional Information:
Certain applications don’t seem to be able to find a browser if Brave is set as the default browser. For example: I use eM Client as my email client application. I got the same error even when I clicked on the Visit Topic link in your email. If I open my mail via web mail in either Edge or Brave, clicking that link always works, i.e., opens in the browser I’m using, not the default.

I put a link in an Excel spreadsheet. Clicking on the link worked with Edge as the default, error message “cannot find application” with Brave as the default.


#2

Hi, maybe the fault is with this client.
Please consider to also report your link opening problem to the developers of this application.


#3

Please read the entire post. The problem also exists with Microsoft Excel. Somehow Brave is not being recognized as the default browser. Highly suspect Brave is the issue. I won’t bother other companies until the problem points to them. Right now, it points to Brave.

Yes, it could be a W10 issue, but Brave probably needs to work around it.


#4

Hi, I deliberately didn’t want to go into Excel. Now you forced me to take a closer look at the pictures. :horse_racing:I have already read your article in its entirety.

You can see that the browser is not even recognized (see first screenshot “Application not found”). This problem could already be solved once by reinstalling Brave. This fixed the problem.
Since Brave was not found, this probably indicates an error offside Brave.

With the 2nd screenshot I suspect again that it’s not Brave.
I don’t really know the message, but the keyword is System, not Brave.

As a solution you could first try to reinstall Brave and hope that it will fix it.

What I remembered while writing is that you may have recently updated Brave from 0.25, and the Windows 10 standard apps still contain the old, uninstalled version.

Translated with www.DeepL.com/Translator


#5

@LeoHamm,
Are you click a link in an email client being viewed in-browser, or is this a separate email client on your machine?


#6

By definition, email client is a standalone application in my PC, not webmail in my browser. As I noted, accessing the link via webmail works by accessing the open browser, not the default browser. As I noted, the same issue occurs when clicking a link in Microsoft Excel.


#7

@LeoHamm,
By definition, troubleshooting software issues involves systematically eliminating possible causes that may produce the unintended behavior. As such, it also requires confirmation of many potential aspects to the situation. It’s logical to consider that there may be a mix-up in terminology or process that could result in us talking past each other. I apologize for the laborious task of confirming that the issue is being understood correctly, but its necessary nonetheless. Appreciate your understanding.

There’s an issue filed for this already. In the thread (linked below), you’ll see another user has found a workaround for this issue, but it’s not an official “fix”. However, the issue is known and will receive an official fix in a future update.


I’ve added your report to the thread as well on your behalf. Please let me know if you have any further questions.


#8

Thanks for the info. Sorry if my comments touched a nerve. I spent 40 years in the computer support business from field engineer to VP, I thought my description and data was very explanatory.

There are multiple locations in my Win10 registry where Brave shows up under “OpenWithProgids”, none of which compare to the fixes listed in the thread you referenced.

So, I’ll just continue to use Edge as my default wait for a fix. I prefer not to mess around with the registry unless it is absolutely necessary.


#9

You can close this issue. I’ll be uninstalling Brave. There are just too many incompatibilities with many web sites that it isn’t worth my time to report them all.

Thanks any way.


closed #10