Brave will not let me browse

Since yesterday I am unable to search ANYTHING using Brave. I have been using it for at least three yers now, but as of yesterday I get this message:
" Too many requests

You’ve made too many requests in the last time. Please, be patient and try again later."

How is it possible to make “too many requests”?
I have tried restarting my computer; and I have uninstalled and reinstalled Brave; still get the same message.

thank you.

Are you experiencing the issue anywhere else besides Swisscows?

That sounds like a message coming from the website server.
Does the same website complain if accessed by another browser from the same IP?
Could it be you are using TOR and the “too many requests” are from the exit node?
Or the ISP gave you an IP that previously made many requests to that site?
If so, perhaps reconnecting to renew the IP can fix it.
By the way that link works for me, I just tried with Firefox, Brave, and Brave TOR.


Thanks for your message.

I cannot open any web site that I enter into search. It does not matter what web site it is, I get that message. I have not used TOR. I do use a VPN. I will choose a different location and see if that helps.

Is swisscows set as your default search engine? Are you visiting the site and searching from there or searching from directly within the address bar? If you go to and run a search, does it successfully complete? Are you able to visit sites from it?

Or are you saying that this is a situation where you cannot visit any website by typing them into the address bar?

Sorted out?
Meanwhile I noticed that if I use Google search within TOR, it has me clicking crosswalks and traffic lights for a good while, complaining of “unusual traffic from my IP”.
I think what’s happening to you is similar, only that the “unusual traffic” source IP is that of the VPN.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.