Brave wallet problem 2

I have created a brave wallet I used a password of more than 10 characters, I wrote it down on paper and then entered it twice as requested in creating the wallet, I then carried on and bought a few pounds worth of ether which after a short time was confirmed to have been transferred to my wallet. I then tried to go back to my wallet using the same paper as I used previously to be told my password was incorrect, trying several times with same result. I am reluctant to try the recovery process in case there is a problem with that. What can I do?

Hello! What version of Brave are you using currently?

Thank you!

The latest downloaded yesterday I can’t find the version no in the browser

The file was brave BROWSERSETUPBRV913. exe

It can be found here: brave://settings/help


I’ve only got help tipped

Found it

Says up to date

Sorry I replied on what i thought was the forum

this is what I got

Brave is up to date

Version 1.60.118 Chromium: 119.0.6045.163 (Official Build) (64-bit)

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.