Brave used to show ads, then couldn't claim ads now doesn't show any ads

I have been using Brave for a while now and in the first few months I was receiving ads and able to claim rewards. For the past few months I was still receiving ads but was not able to claim any rewards despite being able to see how much had accrued each month. This month I have not received any ads at all.

I’m in Australia and use Windows 7 on my media machine and frequently with a VPN. I have used a VPN on and off throughout the entirety of using Brave browser so nothing has changed on my end throughout this time.

I have tried multiple times turning on/off settings and restarting the browser but nothing seems to work to turn ads back on or to claim the previous several months rewards prior to ads no longer displaying.

OS Windows 7 Pro 64-bit
Brave Version 1.2.41 Chromium: 79.0.3945.88 (Official Build) (64-bit)

Your Brave us outdated. The latest version is 1.10.x


Ah you’re right it is outdated. The browser itself doesn’t and hasn’t shown an update icon for a while now though (whereas it did on my Windows 10 machine). Is it safe to manually download brave again and install it over the top to update it? Or will doing so affect wallet/bookmark data/previous session data?

Yes. Make sure you close Brave and run the installer again. No need to uninstall. Just run the installer. It’ll fetch the latest version.

1 Like

Cheers Eljuno, this worked and I was also able to claim the previously few months rewards that I couldn’t claim before :smile:

1 Like

Glad it’s solved your issue, @Lor.

I’m going to close this thread for now. Feel free to open a new one if you have any issue/question.

Thanks for using Brave. :lion: