Brave talk not working

I am trying to use the new Brave talk feature but it does not work. I click on Start free 1:1 call and nothing happens. I don’t know if there is something I should be doing.
I’m using Windows 10 btw.

@Asfar what happens when you attempt to start a call?

Brave talk killing me

Absolutely nothing. Screenshot of the page where I’m trying. Clicking it doesn’t do anything and no loading or anything as well. Also tried to wait a few minutes to see if it was slow.

You got it to work right? Mine doesn’t work at all, cannot start any calls.

Hi @Asfar,
What version of Brave are you using?
(go to brave://settings/help to check your version number)

I’m using the latest one I think. 1.32.106

Are you going directly to or are you doing it from the new tab page?
Can you try clearing cookies/cache via brave://settings/clearBrowserData?

Not sure what the difference is here? I’m trying it in the page with url:
Tried clearing cookies/cache as well.

Try to temporarily disable privacy extensions like UBlock origin or similar, perhaps is the click on the button blocked. I had the same problem the first time, then I whitelisted the domain and worked fine.

After trying the recommendations here, I checked the console.

The console prints: !!! < checking braveRequestAdsEnabled...: {}

Under Settings, Enable Brave Rewards > Ads and viola… It works.

EDIT 1: Now I’m getting ad notifications from Energizer batteries. Unreal.

EDIT 2: You can set to 0 ads per hour and targeting to Disabled.

I’m using brave so that I don’t need any of those extensions. So I’m not using any extensions.

Worked for me too! So basically you need to turn on Ads to use a seemingly free feature. Doesn’t seem very free to me now, will test to see how well it works or else back to ads off.
Thanks btw!