Brave Speed after recent update -- (mostly) PARTIALLY SOLVED


Description of the issue: UPDATE: I most solved this by turning off the new “Memory Saver” management feature. That fixed the problem. In addition, I whitelisted several sites under the section for “Always keep these sites active”. The browser still occasionally lags out, but everything is dramatically improved. YouTube is an example of something that seems to lag the browser and lead to serious freezing/locking up.

Brave takes 2 minutes to load, whereas before it took 10 seconds. Every page is slower. I noticed my system is telling me how much memory each Tab is now. Sometimes tabs appear to be put to sleep to save memory?

I don’t know why this is happening, but it is awful. I have 62GB of system memory, more than enough to run Brave with hundreds of tabs. But the recent update seems to have made everything perform really slow. Can anyone tell me what is wrong?

How can this issue be reproduced?

  1. Start the browser. Wait 2 minutes.
  2. During the loading process, some pages that attempt to resume from before glitch, saying “You may be offline.” Many links won’t work.
  3. The browser finally finishes loading.
  4. Sometimes tabs appear to put themselves to sleep to save memory.
  5. Even 20 minutes after everything loads and seems to be smooth again, some new heavier pages take notably longer to load. (Like Gmail for the first time.)
  6. After loading a new heavier page, other new tabs are slower again for about a minute.

Expected result: The browser should have a ridiculous amount of memory to work with. It used to start up hundreds of tabs within 10 to 12 seconds. Tab were immediately responsive. Now everything is slow, and sometimes things sleep themselves, breaking workflow.

Brave Version( check About Brave): v1.62.156 (Jan 31, 2024)

Additional Information: I’m running:

Operating System: Kubuntu 23.10
KDE Plasma Version: 5.27.8
KDE Frameworks Version: 5.110.0
Qt Version: 5.15.10
Kernel Version: 6.5.0-15-generic (64-bit)
Graphics Platform: X11
Processors: 24 × AMD Ryzen 9 5900X 12-Core Processor
Memory: 62.7 GiB of RAM
Graphics Processor: NVIDIA GeForce RTX 4090/PCIe/SSE2

1 Like

LMDE user here: It seems all Debian based distros are experiencing issues.

That’s good to know it is not me. I recently rolled back the version to 1.61.120 and the problem went away.

I am using the v1.62.147, and no issues at all.

I waited for a few version updates but the problem is still persisting, but not as bad.

The start-up time especially has improved, usually taking only about 30 seconds or less now.

But new tabs sometimes take a while to start, and occasionally active tabs will slow down. This is noticeably can effect other tabs when it starts to happen. Even closing a slow tab might take 4 or 5 seconds.

Sometimes it works quickly and other times it is noticeably slow.

I’m currently running version 1.63.169.

The problem is STILL there. In fact, it may be worse.

So far I have experience a total loss of all my tabs. (I had about 170 tabs open.) I was able to recover them because I don’t trust Brave’s session record keeping and use an extension to keep an extra duplicate.

The memory and speed issues are AWFUL. Tabs will reload then randomly slow down after a few minutes. Videos will simply jerk to a half, and start working again for a few seconds, then freeze-up again.

Copying and pasting into the browser is also delayed, as is copying between tabs and editors in the browser.

Today I downgraded the version to 1.61.120 and ALL the problems disappeared. I had forgotten how fast this browser is supposed to be.

This is a MASSIVE MAJOR ON-GOING CONTINUAL PROBLEM.

How do I fix this please?

I am suffering from the same thing with 32GB of ram and the maximum number of windows is 10 and I use Ubuntu. Today they uploaded an update but the same problem continues.

UPDATE:

I have been hoping the problem would be fixed with browser updates, so I have unpinned the last working version 1.61.120 and allowed it to continue using the current version. (As of writing this the version is 1.64.122). For a while, the problems seemed to mostly better. But then they occasionally return.

The problem is still persisting. Some heavy computation websites, like Gmail or Google Drive, periodically will tell me “You may be offline”.

Today Gmail would not fully load and was only showing partial functionality.

I have noticed if I load the browser with a lot of tabs (about 170), then close about 16 tabs, it suddenly starts working pretty fast again. I don’t know if there is a number of tabs that triggers the problem (over 150-ish?), or if the problem is not allocating enough memory, and by closing those extra tabs the program finally works.

UPDATE 2: Closing a few tabs, then restarting the browser seemed to fix all of the offline issues (at least initially).

Update: Still happening. It is not as bad, but now the browser appears to load mostly quickly at first. Then it works mostly responsively for a short time, maybe 2 or 3 minutes. Then it will lag again, and active pages with strong data connections (like Google Docs) will disconnect. They will report “You may be offline.”

Even minutes later with literally doing NOTHING, the pages will disconnect again and again, lagging the browser very badly. I’m hopeful that the upcoming Ubuntu 24.04 upgrade will offer some fixes for the problem. Will report back. If it does not, I’m filing a bug report.

FINAL UPDATE: I turned off the new “Memory Saver” management feature. That mostly fixed the problem. Almost everything is normal now. The browser will once or twice lag out during the day for some reasons I cannot determine (and require a restart) but then it behaves great again.

In addition, I whitelisted several sites under the section for “Always keep these sites active”.

For mere mortals - who haven’t a clue what ‘memory saver’ is - here’s a link that may help:

Under the heading of ‘clueless’, this was / is the first I’d heard of the ‘Memory-Saver’ option. Looking at the first entry in this thread, my hardware is … primitive. This is under Debian 12 (bookworm) with Cinnamon desktop.

Additional info: I save no tabs when I close Brave (or other browsers).

Upgrading from Debian 11 (bullseye) to 12 (bookworm), I experienced performance and stability issues with Brave (and other applications). Nothing has been consistent or repeatable, hence, not posting about it. It’ll be interesting to see how Brave’s ‘Memory-Saver’ (toggled ‘on’) affects this.

I’m currently running Brave 1.65.126 - not yet downloaded / installed 1.65.130

Happy for you, but the truth is, the issue extends far beyond your case. You merely achieved a temporary workaround. It’s up to the Brave team members to make the real changes to address an issue plaguing many users across both MacOS & Windows. The Kiwi will disregard, per usual.