Brave randomly stoped opening on my mac

**Description of the issue:**today brave randomly stopped opening on my mac. i tried restarting my computer and deleting and redownloading brave from the web but it still would not open.

Steps to Reproduce (add as many as necessary): 1. 2. 3.
just try opening the application on your mac

Actual Result (gifs and screenshots are welcome!):
it shows an opening animation but the application does not open.
it does not show on the doc as running so i am sure it is not opening at all

Expected result:

Reproduces how often:
every time i try to open it

Operating System and Brave Version(See the About Brave page in the main menu):

Additional Information:
when i switch mac user , it works fine on the other accounts but it wont open on mine.

I am on sonoma 14.5

@VenkatPrajwal,
Thank you for reaching out to us.
Sounds like some kind of permissions issue. Are you the admin on the machine?

I am not the admin but i know the admin username and password

i looked through some old posts on here and found a link for an old version of brave which i downloaded and and updated and that seemed to fix the issue. but the problem originally arose in the middle of the day after i used the browser for a while. i am able to use it again but i am not sure if the problem will repeat

I will go ahead and leave this thread open for now so that if the issue reoccurs you can reach back out to us here and we can further troubleshoot.

yes please. and thank you

I had the same issue on windows, where browser wouldn’t open.
One way I found that worked was I made PDFs open in Brave browser, and somehow it magically opens Brave.