Brave mobile google image search

Description of the issue: google search image is not available
How can this issue be reproduced?: using incognito mode (i tried it on normal mode as well, but mostly incognito) search for anything, can be even an example: “nature landscapes”, open it in google images, and then hold on any random picture and use option to search the image in google images

Expected result: google image doesn’t work, gives an error “image search is not available. try again in a few hours” (may be different, translated from my language) and sometimes a page with html code 405, but rarely.

Brave Version: latest update on android
Mobile Device details: android 11

My question is: has anyone experienced this issue? Happens since yesterday on my both devices. Desktop version seems to be working fine, yet android (different brave versions) this issue keeps happening and i couldn’t find any solution around the web. Standard google chrome browser seems to be working fine


I’ve been experiencing the same issue since at least August 30. Both on Brave for Android and my desktop. Keeps saying to check back in a few hours, never works. Frustrating.

I’m guessing it has something to do with Google trying to replace the standard reverse image search with forcing people to use Google Lens?–Google Lens is what pops up when I try the same sort of search (Search image with Google) in Chrome on desktop. (Indeed, when I try the same in Chrome for Android, instead of “Search image with Google,” it now says “Search image with Google Lens (new).”) I think the old press to search for image is being done away with and Brave isn’t updated for it.

I tried looking in the Google Chrome store for an app or addon to handle this but didn’t have luck, then again I’m not good at searching for such things, plus I don’t think they have any addons for Brave for mobile. :confused:

1 Like

Have had the same problem for days now on desktop. Extremely frustrating.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.