Brave iOS Crashes Every Time Private Data is Cleared

Troubleshooting technical issues is much easier when both the user and support agent practice clear communication. For this reason, we have provided the template below for you to fill out with information about your issue. Please provide as much detail as possible so we can most efficiently resolve your problem.


Description of the issue:

Hi Brave Team,

My information are as follows:
Brave iOS Version 1.13 (19.11.06.18)
iOS Version 13.2
Device: iPad Air 2

My browser settings have been changed to use Private Browsing Only, and I have a habit of always clearing the Private Data every time I am done using the browser (just in case). Previously, Brave has always cleared all private data and what will be left on the screen will be a new browser window at the home page.

However, after the recent update, Brave seems to have problems clearing private data. It crashes every time tries to do that, and no data will be cleared. I checked by tapping on History in a newly-launched Brave browser Menu. Every site I visited was listed.

I have tried deleting the app and reinstalling it, but there’s no change. It still crashes every time it tries to clear private data.

Could you kindly look into it and advise please?

How can this issue be reproduced?
*.Please follow the information explained in the above paragraphs.

Brave Version( check About Brave):
Version1.13 (19.11.06.18)

Mobile Device details
iPad Air 2 running iOS 13.2

Additional Information:
None.

Looking forward to your reply.

Thank you.

Regards,
Andrew

3 Likes

Version 1.13 (19.11.06.18)
iPad Pro 2018
iPadOS 13.2.2

Always crashes when trying to clear private data.
PLUS when I check the button to hide the Brave rewards icon, it disappears and reappears.

Thanks

1 Like

I have the same problem, using Brave 1.13 on 6 gen iPad with iPadOS 12.2.2

Having the same issue too.
Brave: Version 1.13 (19.11.06.18)
iPad PRO 2016 iOS: 13.2.2

UPDATE, 11/17/2019

(1) I updated my iPad to iPadOS Version 13.2.2. This did not fix the problem. Brave continues to crash, as described below.
(2) I also tested Brave on my iPhone X and on my iPhone SE. On these devices, …/Settings/Clear Private Data works correctly, and Brave does not crash. Both of these devices are running iOS 13.2.2 and Brave 1.13 (19.11.06.08).

PLATFORM

Brave Version: Version1.13 (19.11.06.18)
Device: iPad Air 2 (Model MH312LL/A). Released October 2014.
OS: iPadOS 13.2.1 and iPadOS 13.2.2.

MY PROBLEM

I have (almost) the precise problem Andrew described. The only difference is that I do not use Private Browsing mode. I have been using the Brave browser on my iPad for a few months. I frequently use …/Settings/Clear Private Data to delete cookies and my browsing history. Up until the past week this command worked exactly as I expected. It also closed any currently open tabs, just as I wished. However, starting this past week, Brave crashes whenever I use the Clear Private Data command; I am dumped back onto the iPad homepage. When I restart Brave all my browsing history is still there. (So far as I know, Brave does not provide means to check what cookies, if any, are currently stored in the browser.) Since Brave Version 1.13 was released at about the same time this problem first occurred, I suspect there is a new bug in this new version. (I always update my apps to the latest version as soon as iOS notifies me that an update is available.)

As Andrew described, I deleted the Brave app from my iPad, powered off my iPad, restarted my iPad, and reinstalled the latest version of the Brave browser from the iOS app store. This did not help. Brave crashed exactly as before.

To reproduce:

  1. Start the Brave browser app on an iPad runing iPadOS.
  2. Turn off, if necessary, …/Settings/Private Browsing Only.
  3. Browse a couple of websites.
  4. Use …/Settings/Clear Private Data/Clear Private Data.
    At this point, Brave crashes, before asking me to confirm that I wish to clear.
  5. Restart Brave browser app
  6. Use …/History to view previous browsing history. All the browsing history from that was present at Step #4 above is still there.

I love Brave browser on my iPad, and I’m looking forward to an update that fixes this problem.

Adam

1 Like

Will be fixed in 1.14. iOS 13.2 introduced this problem unfortunately
More details here https://github.com/brave/brave-ios/pull/1955

Fantastic, Michal.

Any idea when 1.14 will be rolled out?