Brave for Android drop-down menu choices don't work

Brave for Android drop-down menu choices are unresponsive, or nearly so.
I will tap on the selection, and get no response - menu stays there as though I hadn’t touched it.
If I’m very patient and I tap very repeatedly in the lower left margin of the selection area, it might work. Maybe other areas, haven’t tried.
An example of a web page would be https://shop.smalldog.com/product1290.html, while attempting to select features (amount of RAM,etc) to customize a Mac system before purchase.
It works fine when I hook up a mouse to the Android, and use the mouse rather than my finger.
I’ve cleared the history, cookies, and the cache, with no joy.
All works fine in Firefox.
Thanks for any suggestions.

1 Like

@Hchan3,
Thank you for reaching out to us.
On my end – using a Samsung Galaxy S9+ – I’m able to view drop down menu options without any issue. Can you please tell me what type of device you’re using? Additionally, can you try turning Shields down for the site and test to see if this resolves the issue?

Hi @Mattches
I’m not sure if I was clear… I can view the option list, but selecting (tapping on) one does nothing.
Yes, I’m using a Lenovo Tab P11 Pro tablet.
Disabling Shields doesn’t change anything.
Thanks!

@Hchan3,
Thank you for the clarification. That said, this also works for me (selecting the different options). I’m wondering if it has something to do with the type of device being used.

Can you try viewing the site in Desktop mode (with the tab open, tap Main menu --> Desktop site) and test again to see if this resolves the issue?

@Mattches, thanks, yes I’ve tried desktop mode. Problem persists.

I’m getting this issue too. Used to work fine then stopped working in the last few days.

Well, I suppose I’m relieved to know it’s not only me.
I found another thread with nearly the same symptom. Here: Unable to select autofill form suggestions
It’s strange behavior. It behaves as though the ‘Target touch-point’ for this kind of menu has been reduced to a tiny speck for each selection.
I can use Firefox until this has been fixed.

If developers are following this thread, I’ve done a bit of testing, using the Android “Developer Tools”.
It doesn’t seem to matter the location of my tap, as I previously thought.
It seems to be possibly the duration of the touch.
ie: if I tap firmly repeatedly and quickly, it doesn’t register no matter how many times I tap. But if I tap very lightly, repeatedly, a tap will finally register (as though perhaps a micro-second touch is what registers?)
This behavior seems to be repeatable. That is, these extremely-light touches will register after 5 to 15 quick tries.
Dunno if that helps anyone trying to figure this out…

1 Like

Hi, the other post was mine. I commented here for visibility. I’ve considered using another browser too but I do prefer brave generally. This issue gets more irritating every time I encounter it though.

Just tried your repeated light touch technique and get the results as you. 5-15 light taps until one is registered. Tried multiple times on multiple sites. Good spot. Hopefully this will help towards a resolution.

Ah, ok. I didn’t see that it was you.
Do you know, is this the right place to report bugs?

I have the exact same issue since a few days.
Brave version: 1.32.112
On a Lenovo tab TB-J706F with android 10

The same issue here.
1.32.112.
Lenovo Tab P11 (Lenovo TB-J606F), Android 10.