Brave fails to attach files in web forms

Description of the issue: Anytime I need to upload any file into any web form, I get “Aw, Snap!” error. Thus, Brave essentially fails the basic function of file uploads/transfers. And I observe it during already quite long time - probably about a year. This is very important function - hence, needs to be fixed! Below is an example.

How can this issue be reproduced?

  1. Go to, e.g.,
  2. Press File → Load image (in the upper left corner).
  3. Choose any image file from your machine and press “Load” button - and you will see the crush.

Expected result: Files must be loaded properly.

Brave Version( check About Brave): 1.45.131

Additional Information: My OS - Ubuntu 20.

Hi @astrotula welcome back to Community :wave:

Thanks for reporting.

Unfortunately, I am unable to reproduce this issue? Are you able to reproduce this issue on another profile, Brave Nightly/Beta or other browsers? And is this for all images you try to upload?
Do let me know!

Hi, @SaltyBanana!
I’ve discovered now, that Brave Nightly (v 1.48.5) performs this task successfully! But regular Brave - not.
Regarding other browsers - Firefox works ok.

Hi @astrotula

Apologies for the delay.
Does the issue still persist on 1.45.133?

Hi @SaltyBanana , yes.

Thanks for confirming.

Unfortunately, I am not able to reproduce the error.
Have you tried clearing your cache/cookies and test again?
Do you have any extensions/programs/apps that might be interfering with the function of the site?

Hi, @SaltyBanana.
Yes, it may be due to something, which is specific to my machine and browser settings. I will try to investigate.

1 Like

It works OK with my Brave Version 1.46.144

Hi, all and @SaltyBanana !
Finally I switched to new installation of Brave through the official release channel (through “apt install” instead of Ubuntu software store), and it solved my problem!

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.