Brave defaulting to NOT my torrent default app?


If it’s my FIRST click of the day on that particular type of link, I get a warning about “a more recent version is already installed, do you want to keep using the running version?” which doesn’t make sense, i don’t have uTorrent set to start with Windows, so the only way it would be running is if Brave started it, so why is it asking me after the fact?
image

After that, clicking a magnet link gives me an error about uTorrent being already running. of course it is, that shouldn’t keep Brave from sending a link to it.
image

It happens anytime I click a Magnet-link.

It was fine until I updated my uTorrent version to a paid version, which involved reinstalling.
I’ve already checked to make sure the old version isn’t there, it isn’t, checked to make sure uTorrent is set as my .torrent handler in my Windows defaults, it is.

This is the latest version of Brave:
Version 1.25.70 Chromium: 91.0.4472.77 (Official Build) (64-bit)

Additional Information:

EDIT: Actually, I think I’ve resolved it. Still not sure what the heck Brave was doing, but uninstalling uTorrent completely including config files and reinstalling from scratch seems to have solved the problem, clicked links are now opening in uTorrent (whether it’s running or not) as appropriate.