Brave creators activation link not working

When I try to sign up as a creator, I get a link to activate my account but even though I click it right away, it just says it is expired.

I have tried several times but keep getting an error. Looks like there is an issue with the creator sign-up?

Hi @Moeller79, Welcome to Community!
Are you clicking on the button or copy/pasting the URL?

I have tried both and none of the methods are working.

@Moeller79,
Can you send me a DM with the email you use to login to your Creators account so I can take a look on our end?

Thanks. I have just sent you a DM

Hi @Moeller79 – are you able to use the log in button? Try going to the login page, getting a link, then completing the sign up process that way.

When I click the login button and then get a new link, that link will also just say it is expired.

Hi again,

Any update on this?

I’m looking into it this morning, will get back to you soon.

Hi @Moeller79 I sent a login link your way, let me know if it works. If it does, then I have found a bug in our system I’ll patch today.

It is still not working

OK I just sent 2 new login email: it looked like one of them someone attempted to use: did you open either one?
If not, it looks like /something/ may have clicked on the link before you got to it. If so, I’d recommend changing email software, computers, or even using a different email address.

Tyler

This could be your email software: is it trying to preview the link? If so, it actually /visits/ the link to view it and uses the one-time code. You’ll need to turn previews off.

It was me clicking it when I got the email.

And I just tried the second email you sent as well and still get the error.

OK let’s try this one more time: Can you try this link? You’ll need to remove the spaces and then go to the link: (one after https, one after publishers. and one after .org )

https: //publishers. basicattentiontoken.org /publishers/b41dedfb-9147-46ed-af8e-4c297be78b77?token=fb1fc0e18eb1d78d68307dacc61f2e4111cd4ab2101af15b6044df6dff7fac6a

If this works then we know that someone along the way is viewing your link before you get it. If that’s the case, is it possible for you to try another email with another email client? We have a current limitation in our system that allows only 1 visit to that link and it appears that someone or something else is visiting the link before you do. We’re looking into loosening the rules.

It worked now after I removed those spaces. Very strange.

But I have now been able to create my account. Thanks for your help.

OK great glad it worked. It looks like some process along the way is visiting the link we send you. I don’t know what it is, but I think you’ll need to figure that out, or use a different email client, or set up a new account with a different email that doesn’t do that.

Thanks for your help.

I keep having problems logging in and think it will be better to use a different email. Is there a way you can change the email for my account? Because I cannot log in myself to see what is possible as I keep getting an error when trying to access with the link I need to click every time I need to log in.