Brave crashes on macOS Monterey 12.0.1

Hi, I am trying to install Brave on my new MacBook Pro (Monterey 12.0.1), Apple M1 Pro chip, but after the install, when I try to open Brace - it crashes. I get a message that Brave quit unexpectedly.
I tried to un-install, restart the computer and re-install, but this does not help. Please advise. Thank you


Good idea to make routine backups of the BraveSoftware folder:

/Users/[username]/Library/Application Support/BraveSoftware/

Original installation of Brave Browser, creates a Default folder that is the original Profile of the user:

/Users/[username]/Library/Application Support/BraveSoftware/Brave-Browser/Default/

Bookmarks file:

/Users/[username]/Library/Application Support/BraveSoftware/Brave-Browser/Default/Bookmarks

1 Like

Thank you, looks like removing folder Users/[your user name]/Library/Application support/BraveSoftware solved the issue. Regards


I have experienced the same issue. My question is this when you download Brave and you select the M1 chip in lieu of Intel the M1 chip indication never changes color to indicate that you have selected it. Is there any way to determine which version has been downloaded and installed?


In a Brave Browser > New Window, go to: brave://version/

List of Brave URLs: brave://chrome-urls/#internals

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.