BRAVE does not start on my new MacbookAir M1

Description of the issue
BRAVE does not start
Only the crash report window is displayed

How can this issue be reproduced?
every time I try to launch BRAVE

Expected result
Brave is launched and I can surf the web…

Brave Version( check About Brave)
The latest for MacOS M1, just downloaded from

Additional Information
I just have a brand new MacBook Air M1. So I never run any version of brave on it

@Cinq , @peterk ,@Steve122 , @pdemosthenes , @13847t ,

You all have had troubles with successfully launching Brave Browser; and the following info may help you.

@ZiG-ZaG and @CiscoCampos have reported, that removing the “BraveSoftware” folder

/Users/username/Library/Application Support/BraveSoftware

. . . fixed the problem:

@jelacou confirmed that, and states:

“The BraveSoftware folder is recreated when Brave is started, but does not prevent Brave to start anymore.”

Brave crashes upon launch on brand new M1 iMac 12.1 - #16 by jelacou

@RunoE used a different approach (via the command line) in order to remove the “BraveSoftware” folder:

(I suggested: Quit Brave Browser BEFORE running that window command.)

Three Mac OS Crash Reports have been posted re “failure to launch” problem. Brave Browser was the cause of all three crashes. (Also, Siri is having a problem; see “Siri troubles” later, below.)

OP by @RunoE
New mac, Brave Browser quit unexpectedly

New mac, Brave Browser quit unexpectedly

OP by @Steve122
Error trying to install on MacOS m1 chip

Error trying to install on MacOS m1 chip

OP by @jelacou
Brave crashes upon launch on brand new M1 iMac 12.1

Brave crashes upon launch on brand new M1 iMac 12.1

Siri troubles – some discussion at MacRumors:

PS: Over time, I found that it has been a good idea, to Restart a computer before installing an application, and letting the computer settle down a while (after the Restart), before running the installation. (For Windows OS machines, create a System Restore Point, before that installation.)

@Steve122 – Not picking on you . . . just considering your M1 Crash Report as an example: Your computer appears to have been brought out of Sleep, prior to the Brave Browser installation; but, better to do a Restart before installing.

You might consider Disabling Siri involvement with Brave Browser. You could Re-Enable, later, when things settle down, if you wish.

/Users/user_username/Library/Application Support/BraveSoftware

I can’t seem to find the folder, I have tried following the steps.

Tried uninstalling and reinstallling Brave.
Brand new M1 on Monterery OS.

Happed to me. Open terminal and type in “sudo rm -rf ~/Library/Application\ Support/BraveSoftware”
like @289wk said I recommened closing the brave browser first.

1 Like


Thanks for the info on this, I deleted the folder and it started working.

1 Like

Thanks :pray:
That’s good ! I deleted the App support folder and brave is OK

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.