Brave crashes often on tablet using iPadOS 16.3.1 (20D67)

Dear Michel,

Please find enclosed the requested files I think it is in the file of April 1st, but I send you the ones of March 31st and April 2nd just in case. Strangely I cannot reproduce the bug anymore. It works now, without I did any update on the iPAd.

Thank you for your contribution to the development of Brave.

Best regards,


(Attachment is missing)

(Attachment is missing)

(Attachment is missing)

Dear Jean-Michel,

Strangely I cannot reproduce the bug anymore. It works for me now (iPad Pro 2018), without having done any update on the iPAd.



Dear Michal,

Apparently the system rejected the attachements I have sent you. My answer to you was:

"Please find enclosed the requested files I think it is in the file of April 1st, but I send you the ones of March 31st and April 2nd just in case. Strangely I cannot reproduce the bug anymore. It works now, without I did any update on the iPAd.

Thank you for your contribution to the development of Brave."



I have exactly the same issue for three days now.

Discription of the issue: Cannot open settings from main menu.

How can this issue be reproduced: Each time settings is selected from the main menu.

Brave version: 1.48.1

Mobile Device details: Ipad pro 2022
Ipad OS 16.4.1

@michal I know I tagged elsewhere on people trying to get logs to you, but going to tag here again. The Support page at doesn’t let anyone upload files. How are you expecting/wanting people to get those crash logs to you?

Asking as we still have people sharing of their iOS devices crashing. If that information is being collected, I want to make sure we can direct people on how to get that info out.

I’m having this problem on iPad Pro 3 Gen with iPad OS 16.4.1. Brave starts but crashes immediately when opening settings. I just installed it to try it out. It works fine on iOS and MacOS.

Can you share logs with us?

I feel the fix is not hard but so far we have not been able to see any logs for this type of crash

Feel free to DM me if you can’t upload logs here, probably some security measures sorry

@michal Just a reminder, Users can’t initiate DM anymore. So if you haven’t sent them a DM, they will have no way to DM you. And support tickets no longer allow Users to upload files either.

Forget if trust level dictates which types of files, but on my alt account I just tried and it shows: Just tested on this and alt account, types of files that can be uploaded here on Brave Community are restricted, as you can see below:

So it MIGHT be possible if they try to upload as a .txt file but otherwise it’s images only pretty much.


I also just went to my iPhone and attempted to upload a .ips file. It did the same thing:

TL:DR of the above is that Users can’t upload files here. So even in DM (which Brave staff have to initiate), they won’t be able to share .ips that the crashes are contained. And no way to upload on support ticket. This limits to email only or for them to use a file sharing service and sharing link with you.

Unless you, @Mattches, or someone else has a better solution.

Ahh I see. The file can be renamed to .txt extension and shared with us then, i know it’s a bit of work. I wish we could have more seamless way to do so :frowning:

Still working on the above, thanks @Saoiray


Crash file related to Brave crashes often on tablet using iPadOS 16.3.1 (20D67) - #15 by michal

Let me know if this comes through.


@TonyCr the answer is it didn’t come through. Originally I saw orange like could be clicked, but that just was the link to his post containing instructions. I know from my iPhone I tried to rename the .ips to .txt but it stayed as a .ips file and couldn’t be uploaded. Well, still remains true what I just did a strikethrough, but that’s only when you first save it. That’s because iOS slaps on the .ips at the end again. So rename once more and it becomes .txt, it asks you for confirmation about changing the file extension. So if you save it to your device, go to where you saved it and rename to .txt at the end, then do the confirmation to .txt you should then be able to upload the file here.

Had that not been working, or even beforehand, it would have helped if they just would have provided you their Brave email or changed the site here to allow different format. It shouldn’t be difficult like this, but unfortunately there’s just a disconnect on how Brave has things set up at this time.

Since there’s been the delays here already, what I’ll advise for you to do is just to email it to me if it might be easier for you. I’m going to give you an alternative email account of mine I don’t use, which is If you send it there, I can jump through some of the hoops and hurdles to provide it to them and so it’s not so stressful/annoying for you.

So you can email to me and I’ll change format or do what needs to be done so they can receive your crash logs, you can modify the file and share yourself, or whatever you want done.

Sorry it’s been so much trouble. And yeah, I edited this for clarity and to change tone I had originally. Hopefully not confusing to you and whichever you choose, we can get this through and Support and Developers can figure this out.

It’s on the way via the email address. Thanks so much.

I was able to get it and sent it over to them. Often I don’t see them active over the weekend, so it may not be until after Monday that they respond any further. But wanted to at least reply here to let it be known it’s received and passed along to them.

Quite alright. I appreciate the great response.


Hi Tony, more questions:

  • Do you use your iPad with any keyboard or mouse attached?
  • Did you enable some iOS accessibility settings?

We received the crash logs and are currently investigating. Unfortunately it crashes at high level and it’s not easy to pinpoint it to any specific part of our codebase

I have it on an Apple Smart Keyboard, no mouse. I took it off and tried it. I could get to settings without any problem. I put it back on the keyboard and it still works OK. Not sure what’s going on. I’ll keep trying it to see if the problem happens again. If so, I’ll let you know. If not, I guess it was one of the many gremlins that hang out in electronic devices and he was chased away.

Thanks for your help.

Thanks for letting us know. It looks like a mix of an Apple and ours code.
We have one idea how to fix that but we have never been able to reproduce that even with the keyboard attached

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.