Brave can only launch in incognito mode

Description of the issue:
I cannot launch brave anymore. (This happened suddenly). See additional below for a dump of the terminal errors.

Work around:

  1. Open brave in Incognito Mode (right click, new incognito window)
  2. From settings, choose Create a new profile
  3. Click back (top left)
  4. Choose your profile

How can this issue be reproduced?

  1. Open terminal
  2. brave

Expected result:
Brave launches

Actual result:
The brave window is opened, with absolutely nothing in it - no menus, no tabs, it is just blank, I can only close it.

Brave Version( check About Brave):
Version 1.29.76 Chromium: 93.0.4577.58 (Official Build) (64-bit)

Additional Information:

Launching from a terminal window:

Gtk-Message: Failed to load module "xapp-gtk3-module"
Gtk-Message: Failed to load module "canberra-gtk-module"
Gtk-Message: Failed to load module "canberra-gtk-module"
[0902/085816.694622:ERROR:process_memory_linux.cc(42)] open: Permission denied (13)
[7230:7230:0902/085816.763584:ERROR:profile_attributes_storage.cc(839)] Failed to PNG encode the image.
[7230:7246:0902/085816.879652:ERROR:gpu_process_host.cc(961)] GPU process exited unexpectedly: exit_code=132
[0902/085816.885761:ERROR:process_memory_linux.cc(42)] open: Permission denied (13)
[7230:7246:0902/085816.998121:ERROR:gpu_process_host.cc(961)] GPU process exited unexpectedly: exit_code=132
[0902/085817.003588:ERROR:process_memory_linux.cc(42)] open: Permission denied (13)
[7230:7246:0902/085817.109895:ERROR:gpu_process_host.cc(961)] GPU process exited unexpectedly: exit_code=132
[0902/085817.115519:ERROR:process_memory_linux.cc(42)] open: Permission denied (13)
[7230:7246:0902/085817.214160:ERROR:gpu_process_host.cc(961)] GPU process exited unexpectedly: exit_code=132
[0902/085817.219665:ERROR:process_memory_linux.cc(42)] open: Permission denied (13)
[7230:7246:0902/085817.321227:ERROR:gpu_process_host.cc(961)] GPU process exited unexpectedly: exit_code=132
[0902/085817.327711:ERROR:process_memory_linux.cc(42)] open: Permission denied (13)
[7230:7246:0902/085817.426857:ERROR:gpu_process_host.cc(961)] GPU process exited unexpectedly: exit_code=132
[7353:7353:0902/085817.432001:ERROR:gpu_init.cc(441)] Passthrough is not supported, GL is disabled

You can’t switch it even when you click the option? I notified an admin about the issue as well.

Hi there,

Yes as the work around suggests, it works when you click on the user profile - i.e your profile is loaded, and everything works as if you had just opened brave.

Hope this helps

Just an update on this…

I reverted to a previous version of Brave and that solved the issue (although I am now on an older version of Brave).

cmd:

sudo snap revert brave
brave reverted to 1.28.106

Brave now opens with my profile as expected.

Additional:
When refreshing the snap:

sudo snap refresh brave
brave (beta) 1.29.76 from Brave Software (brave) refreshed

I end up with the same faulty behaviour.

This seems to have resolved itself now. With the latest snap update i.e:

Version 1.29.80 Chromium: 93.0.4577.63 (Official Build) (64-bit)

I was having the same issue. I followed the steps below, and the issue fixed itself:

  1. Right-Click Brave and open ‘New Incognito Window’
  2. Right-Click Brave and open ‘New Window’
  3. Brave asks who is Using Brave - I delete Person 1 profile, and Select do not ask this at startup.
  4. Close all Brave windows
  5. Launch brave - and it works! Opens it with my user profile.