Brave shields block extension that connects to local server through websocket connection

I use the extension firenvim to connect to a local neovim server to edit the text in a browser’s textarea. The extension connects to the neovim server through a WebSocket connection. Brave shields seem to block this connection (unless it’s on localhost) as a cross-origin request, is there a workaround or a way to allow the shields to allow this connection?

The extension works as expected in chromium and firefox.

Brave version:
Version 1.18.70 Chromium: 87.0.4280.101 (Official Build) unknown (64-bit)
installed using brave-bin from the AUR

2 Likes

Yeah, I have the same problem with my Firenvim extension and Brave.

Does turning off shields ads/trackers help (on the select neovim pages)?

I can confirm - disabling brave shields does solve the problem. (But it is not the ideal way-around)

In Trackers and Ads, in Shields. What is showing blocked?

When I’m on Github for example, it is showing me this:

  • .api.github.com/_private/browser/stats
  • .collector.githubapp.com/github/page_view?dimensions[page]=https%3A%2F%(…)
  • 127.0.0.1:51917/262835903421922810982040566138321824521569596882146373460830803126693647243279

Ah yeah, The reasoning we block localhost by third-party sites (and in this case extensions).

There a few sites using 127.0.0.1/localhost fingerprinting users (ebay for example), which is why its blocked by default.

If you need this extension, recommendation would be to disable site trackers/shields globally in brave://settings. And use a adblocker extension as a replacement for brave adblock.

1 Like

I see, thank you for taking your time to help us figure this out!

1 Like

I am having similar issues: on a website that connects to local ws server, I get error 1006 with and without brave shield.

Possibly a site issue? But we’re only blocking localhost request via shields. (disabling will allow 127.0.0.1/localhost requests)