Brave browser crashes instantly on opening. Mac OS Monterey

Brave browser crashes instantly on opening. Mac OS Monterey version 12.7.3. This is the first time I’ve installed it on my 2015 Imac. I’ve tried multiple installations including Beta version. Same crash outcome each time. Others have mentioned deleting the Brave Software folder in Application support has solved this issue for them. I do this and still have the same issue of an instant crash. When I click open on the Brave Icon it crashes within one second every time. Not sure how to fix this issue or if I simply cannot run Brave on this machine. Any insight?

Brave version 120.1.61.120

Same problem here except running Mac OS Sonoma 14.2.1. Brave works flawlessly all day but after sleeping at night, the next morning all tabs have crashed. The only way to start again is to 1) Force Quit Brave, 2) restart the laptop, 3) restart Brave and “restore all pages”. To say this is frustrating is an understatement! I’ve spent weeks reading forums and I can’t find anything about how to fix this issue. If I simply force quite Brave and try to start it again, the icon only bounces in the dock and never opens; I’m forced to restart the laptop. I’m running Brave version 1.62.162 Chromium 121.0.6167.164.

I also have issues with Brave constantly hungs itself and has done for a few months now…
Ventura 13.5.2 and Brave Version 1.62.165 Chromium: 121.0.6167.184 (Official Build) (arm64).

Need to kill it several times per day, uninstalling or clear cookies, history etc doesn’t help…