Brave ads pop-up position?

Description of the issue:
Starting today, Brave ads pop-ups show-up on the top-right portion of the active window, instead of the usual bottom-right notifications I had been receiving. Tried the Push Notification test and that shows-up on the bottom right, ads do not.

I’ve looked through the settings but haven’t been able to find any option that would allow to select where the pop-up gets displayed. Any idea if this is a new feature and can it be customized (I would prefer to have the ad pop-ups on the bottom-right of my window).

Brave Version( check About Brave):
1.30.86 Chromium 94.0.4606.61

Same here. I stopped using Brave in beta because it was doing this. It’s highly distracting/annoying. I have always used sponsored ads on the new tab page to collect BAT. I’d prefer to keep doing it that way and have this new pop up as optional.

@Mattches is there a way to turn this off without turning off ads altogether?


@Jebedaias, @752bfc1c933407ba6a19
Can you share a screenshot of how the ads appear on your end?

Same! I created this topic because I thought it was intended: Ads now at top right?
v1.30.86, Desktop, W7.

They now cover the “close” button on most apps. Stupidly annoying. Placement should be customisable to the corners and top/bottom centre of the screen.

The Ad format looks slightly different, too. But either way as of today they’re all at the top right:

Okay I just needed to make sure this was the type of notification you are seeing. So these are actually new custom ads that we will be using moving forward. Note that you can click and drag these ads around the screen to any new position, which is where they will continue to appear.

That said, these ads should not be appearing unless you have system notifications disabled. Can anyone here check and confirm whether or not they have system notifications disabled in Windows (you can find this on the Notifications and actions page)?

@Mattches is there anything I can look for, as well? My ads are looking just like BobT36’s, and I’m on Linux Mint 18.3 and 20.2 (both 64-bit cinnamon editions).

I have also noticed that window rendering is very sluggish, like since the latest update it has stopped using hardware acceleration to render, if that makes sense? The most obvious is when a new window comes up, regardless of what is “behind” it, Brave draws the desktop background image, THEN draws the contents of the new window.

Please read my previous reply:

Getting these new ads and system notifications is all on…

Thank you for confirming – appreciate it. We’re looking into the issue right now. I’d like to again note that these notifications are still being tested (obviously) but will be the way they ads appear moving forward.

I would also (again) like to point out that these ads can be dragged anywhere on the screen to the desired position, where new ads will appear from that point on.


No worries… I actually don’t have an issue with the new ads, just answering your call… :+1:

1 Like

The Notifications Control Center applet shows Notifications as “enabled,” which means it has not changed since I installed Linux Mint on these machines.

Also, I don’t really have an issue with the ads placement, themselves, but the rendering changes since the last update is what has me worried.

Thankyou, that’s cool that you can drag them anywhere. I’ll try it the next time one shows.
I don’t have the Notifications page btw as I’m still on W7 Ultimate x64.

@megaspaz (and anyone else here)
Can you go your Windows search bar, type in About this PC, scroll down in the resulting window and share a screenshot showing the Windows specifications section?


Thank you for confirming.

So basically what’s happening is that Chromium does not support native/system notifications on builds prior to Windows OS 17134 – as such, the browser defaults to the custom ad notifications, which is why you (and everyone in this thread) are seeing the custom ad notifications.

Again, it’s worth noting that this is not a bad thing, as these custom notifications are the way all ads will looking as we move into future builds.

Yeah, sorry… I had already left work for home… But, I will say that my version of Win 10 is older than what @Jebedaias posted…

Apologies. I didn’t realize this was a Windows thread. I’m on MacOS, but the behavior is the same. Here is what my ad looks like I have notifications turned off for Brave in MacOS system preferences, but that’s been the case. Nothing has changed, except I’m suddenly seeing this.

I’d just prefer to see ads on the new tab page, which I use frequently and am not caught off guard by. When they distract from my attention while working, because I’m not expecting them, that’s an issue. Hope this is considered.

what version you running? I have the old notifications on Mojave 10.14.6… interesting…

MacOS 10.13.6 and Brave 1.30.86. This just started in the last day or so. Not sure if Brave updated and changed something. I downloaded Brave in beta months ago and was quickly turned off by the new notifications, so I figured this was inevitable.

@Mattches if I turn notifications on in MacOS notification center, will this stop these ads? I generally keep my system on do not disturb anyway when working.

Note that I’m on W7.

By “Chromium doesn’t support…” I presume you mean the version of Chromium in whatever version Brave must have updated to yesterday? (29th). Was seeing the “non-custom” notifications up to 29/09/2021.

Dragging them does indeed have it remember the position, so thanks for that. Happy enough now.