Blocker menu covering element

Brave blocker element selector is covering the element I want to block.

For reference; I’d like to block this question mark.
BraveBlock

I often use the blocker to remove unwanted elements from webpages, so this isn’t a one site deal. I’ve ran into this issue multiple times.

Link to the site/element you’re trying to block? @ClaskoTheKnight

https://ntreis.remine.com/engage
Good luck getting there

I get a login, user/pass. The other option would be using right-click, inspect and picking the elements manually. If unsure, right click inspect and post the screenshot here

I found another site that has this problem. This one doesn’t require login.

I’d like to not have a one-off solution, as this is a reoccurring issue.

Can you elaborate more on the inspect to block workflow?
I know html, but I don’t know how brave blocker finds “#ember4” from it.

Page loaded okay here @ClaskoTheKnight what is the issue with the chasecorp page?

There is an icon in the bottom right corner being hidden by the brave blocker pop up.
image

Oh, I found another element in the bottom right corner I’d like to block, but it is covered by the brave blocker popup.

How do I block elements that are in the bottom right corner, but are covered by the brave blocker popup?

https://service.ringcentral.com/application/users/users/default
image

For ChaseData Corp, put support.chasedatacorp.com##.zsiq_floatmain.zsiq_theme1.siq_bR in the Create Custom filters box at brave://settings/shields/filters. Works for me but I really don’t know if this is the proper string that should be used or not.

I picked up the element name using devtools and just created the filter in custom filters. I really don’t know anything about custom filters or devtools so I may not have picked the right area to block or used the proper syntax for blocking. Hopefully it is all ok and won’t cause a problem for the long term. Can always remove it if it does!

I couldn’t try with the other two you linked, but you can try creating yourself. Just look up the element name in devtools, then go to custom filters and put the website main url followed by ## and a dot. (##.) then put the element name. Anywhere there is a space in the element name, put a dot instead.

Again, don’t know if this is the “proper” way to block the element, but it works. Links to information you may find helpful if you want to learn more about devtools and blocking elements:

Main site for devtools documentation:
DevTools Documentation

Elements section of devtools documentation:
Elements

Brave Support Help and a Community topic. Both are outdated but both do provide useful information and visuals:

How do I block additional page elements?

How to use Brave’s “Cosmetic Filter” to block undesired page elements

Maybe someone who actually knows what they are doing can drop in with corrections and a mini tutorial! Hope this helps. Take care. :slightly_smiling_face: